Project

General

Profile

Bug #5653

Geon ArrayContains is a duplicate of a Ptolemy actor

Added by Christopher Brooks about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
actors
Target version:
Start date:
08/06/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5653

Description

./actors/src/org/geon/ArrayContains.java

FIXME: Duplicate of ptolemy/src/ptolemy/actor/lib/ArrayContains.java
Efrat is credited in the ptolemy version?
Deprecate the geon version, extend the ptolemy version.

History

#1 Updated by Derik Barseghian about 7 years ago

Kepler already uses the Ptolemy version of ArrayContains. The implementations were essentially identical. I removed the Kepler version.
I'm not going to bother adding entries to our filters for actors that don't show up in the tree -- let me know if people disagree w/ this line in the sand. See r30697

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5653

Also available in: Atom PDF