Project

General

Profile

Bug #5702

GUI bug - Initial actor port positioning is wrong

Added by Derik Barseghian over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
interface
Target version:
Start date:
08/31/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5702

Description

In the last week or so I've begun seeing a few GUI anomalies on trunk. One is:

Actor port positioning isn't correct on initial actor instantiation.

Replicate:
Drag out Display actor from library.
Observe bug: input port isn't centered (attached).
It may take a few tries to replicate.

Ports snap into place when you move the actor.
The problem is worse for actors wil many ports, w/ output ports floating in the middle of the actor (attached).

This doesn't happen in vergil.

Wrong_Port_Position1.png (5.35 KB) Wrong_Port_Position1.png Derik Barseghian, 08/31/2012 01:37 PM
Wrong_Port_Position2.png (6.52 KB) Wrong_Port_Position2.png Derik Barseghian, 08/31/2012 01:37 PM
Positioning_problems_in_actor_doc.png (134 KB) Positioning_problems_in_actor_doc.png Derik Barseghian, 08/31/2012 01:52 PM

History

#2 Updated by Derik Barseghian over 6 years ago

Dan notes he's been seeing this a lot in actor documentation frames (see attachement). Note how the parameters also overlap the actor.

#4 Updated by Derik Barseghian over 6 years ago

I'm no longer seeing this. A ptolemy change must have fixed it...
Dan can you replicate anymore?

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5702

Also available in: Atom PDF