Project

General

Profile

Bug #5712

illegal option chmod error during Kepler startup

Added by Derik Barseghian over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Category:
general
Target version:
Start date:
09/18/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5712

Description

Today during startup of trunk I started noticing this message on mac 10.8.1:

[run] Building Kars...
[run] start of workflow-scheduler-gui module initializing
[run] <OS>Mac OS X</OS>
[run] ### chmod: illegal option -- -
[run] usage: chmod [-fhv] [-R [-H | -L | -P]] [-a | +a | =a [i][# [ n]]] mode|entry file ...
[run] chmod [-fhv] [-R [-H | -L | -P]] [-E | -C | -N | -i | -I] file ...

History

#1 Updated by Daniel Crawl over 6 years ago

In org.kepler.ssh.LocalExec, copyFile() calls chmod --reference. This option does not exist on Mac. I bet this method is now being called after removing the duplicate file copy code.

#2 Updated by Sean Riddle over 6 years ago

Yes, this is caused by the call on line 104 of tagging/src/org/kepler/module/tagging/Initialize.java.

#3 Updated by Daniel Crawl over 6 years ago

I updated LocalExec.copyFile() to no longer call chmod --reference on Mac.

To reproduce, remove $HOME/.kepler/cache-2.4/modules/tagging/ontology_catalog.xml, and start Kepler with a suite that includes tagging.

#4 Updated by Derik Barseghian over 6 years ago

I still get this error message when starting e.g. the sensor-view suite on trunk head.

#5 Updated by Derik Barseghian over 6 years ago

Fixed at r30991. sensor-view-utils-1.0.jar in sensor-view suite needed to be updated to include change to LocalExec.

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5712

Also available in: Atom PDF