Project

General

Profile

Bug #5839

Save for later may add duplicate 'codeDefinition' elements without defining the code

Added by ben leinfelder over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
01/30/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5839

Description

Shirley Han got this error message for a package she was editing.
Problem with saving to metacat in EML200DataPackage!
<error>cvc-complex-type.2.4.b: The content of element 'codeDefinition' is not complete. One of '{definition}' is expected.</error>

It had some wide dataTables and she had used the "save for later" option during the attribute documentation process.

I looked at the EML file and saw that many codeDefinition elements had been added but did not contain the <definition> element, only the was present. I am not sure how this was introduced or if it was even because of the "save for later" feature. example snippet from EML: ------------ <enumeratedDomain> <codeDefinition> <code>No</code> </codeDefinition> <codeDefinition> <code>Yes</code> </codeDefinition> <codeDefinition> <code>No</code> </codeDefinition> <codeDefinition> <code>Yes</code> </codeDefinition> <codeDefinition> <code>No</code> <definition>No, the course is not required</definition> </codeDefinition> <codeDefinition> <code>Yes</code> <definition>Yes, the course is required</definition> </codeDefinition> </enumeratedDomain>

History

#1 Updated by Jing Tao over 7 years ago

I tried to save an incomplete eml document with the code definition. Then I opened it and continued to work on it. I could save it successfully into the network - so there is no duplicate "codeDefinition" without defining the code.

So I can't reproduce the bug. Ben, do you have more information.

#2 Updated by ben leinfelder over 7 years ago

Unfortunately there's nothing more to go on. We'll just keep an eye out for it again.

#3 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 5839

Also available in: Atom PDF