Project

General

Profile

Actions

Bug #5868

closed

Some weird behavior when morpho deletes a network data package with data file

Added by Jing Tao about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - dsp
Target version:
Start date:
02/14/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5868

Description

Here are the steps to produce the issue:
1. Use the new data package wizard and entity wizard to generate a data package.
2. Save it to network.
3. Go to File|Delete to delete the data package.
4. Morpho shows up a warning panel without any information.
5. The morpho frame does show up (It should disappear).
6. Morpho search on the network can't find the data package. It means that the data package does be removed.

When morpho delete a data package without data object, it works.

Actions #1

Updated by Jing Tao about 11 years ago

The problem is there is no null check for the id. If an id is null, the anotherId.equal(id) will have NullPointerException.

Actions #2

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 5868

Actions

Also available in: Atom PDF