Project

General

Profile

Bug #5889

Update documentation and installers to require Java 7

Added by ben leinfelder almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
03/08/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5889

Description

ECP is using OpenSAML 3.0 that is now requiring Java 7.

History

#1 Updated by ben leinfelder almost 8 years ago

Actually, I decided to downgrade OpenSAML to the stable released version of 2.5.1 which does not require Java 7. The development leaders of OpenSAML estimated that 3.0 would only be in RC stage in mid-2014 which seems too far out to wait for and we don't want to release a product (Morpho) built on shifting sand.

I have done the refactor in ECP library and committed to github repo. Hudson is building it and Morpho is pulling it in. Still using ECP snapshot, but that can be tagged at any time when we are happy with the use of OpenSAML 2.5.1.

#2 Updated by Redmine Admin almost 8 years ago

Original Bugzilla ID was 5889

Also available in: Atom PDF