Project

General

Profile

Bug #5895

HelloWorld link is broken under Kepler-2.4rc3

Added by Christopher Brooks over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
03/20/2013
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5895

Description

Under Linux, the links to the demos fail? It seems like $CLASSPATH is not be expanded?

java.io.IOException: Failed to find file:/home/cxh/src/kepler-2.4RC3/common-2.4.0/configs/ptolemy/configs/kepler/$CLASSPATH/getting-started/04-HelloWorld.xml, also tried
null and
null
at ptolemy.actor.gui.HTMLViewer.hyperlinkUpdate(HTMLViewer.java:342)
at javax.swing.JEditorPane.fireHyperlinkUpdate(JEditorPane.java:345)
at javax.swing.text.html.HTMLEditorKit$LinkController.activateLink(HTMLEditorKit.java:877)
at javax.swing.text.html.HTMLEditorKit$LinkController.mouseClicked(HTMLEditorKit.java:676)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:270)
at java.awt.Component.processMouseEvent(Component.java:6507)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3321)
at java.awt.Component.processEvent(Component.java:6269)
at java.awt.Container.processEvent(Container.java:2229)
at java.awt.Component.dispatchEventImpl(Component.java:4860)
at java.awt.Container.dispatchEventImpl(Container.java:2287)
at java.awt.Component.dispatchEvent(Component.java:4686)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4501)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
at java.awt.Container.dispatchEventImpl(Container.java:2273)
at java.awt.Window.dispatchEventImpl(Window.java:2713)
at java.awt.Component.dispatchEvent(Component.java:4686)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:707)
at java.awt.EventQueue.access$000(EventQueue.java:101)
at java.awt.EventQueue$3.run(EventQueue.java:666)
at java.awt.EventQueue$3.run(EventQueue.java:664)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
at java.awt.EventQueue$4.run(EventQueue.java:680)
at java.awt.EventQueue$4.run(EventQueue.java:678)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:677)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:211)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:128)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:117)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:113)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:90)
Caused by: java.io.FileNotFoundException: /home/cxh/src/kepler-2.4RC3/common-2.4.0/configs/ptolemy/configs/kepler/$CLASSPATH/getting-started/04-HelloWorld.xml (No such file or directory)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(FileInputStream.java:138)
at java.io.FileInputStream.<init>(FileInputStream.java:97)
at sun.net.www.protocol.file.FileURLConnection.connect(FileURLConnection.java:90)
at sun.net.www.protocol.file.FileURLConnection.getInputStream(FileURLConnection.java:188)
at java.net.URL.openStream(URL.java:1035)
at ptolemy.actor.gui.EffigyFactory.checkForDTD(EffigyFactory.java:127)
at ptolemy.actor.gui.PtolemyEffigy$Factory.createEffigy(PtolemyEffigy.java:384)
at ptolemy.actor.gui.EffigyFactory.createEffigy(EffigyFactory.java:233)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:1079)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:1005)
at ptolemy.actor.gui.HTMLViewer.hyperlinkUpdate(HTMLViewer.java:293)
... 35 more

History

#1 Updated by Daniel Crawl over 6 years ago

The links to demos in Help -> Kepler Documentation work for me. I tried both

java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.3) (6b27-1.12.3-0ubuntu1~10.04.1)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)

java version "1.7.0_11"
Java(TM) SE Runtime Environment (build 1.7.0_11-b21)
Java HotSpot(TM) 64-Bit Server VM (build 23.6-b04, mixed mode)

on Ubuntu 10.04.

#2 Updated by Daniel Crawl over 6 years ago

To reproduce, delete KeplerData/workflows/module/outreach-2.3* and start Kepler. The links will not work (regardless of OS). If you start another Kepler, the links work. The problem is that the first time Kepler starts with a new version of the outreach module, the outreach demo workflows are not in KeplerData and are not added to the classpath.

I fixed in r31698.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5895

Also available in: Atom PDF