Project

General

Profile

Bug #613

verify/fix synchronize/export/delete for data package window

Added by Matt Jones about 17 years ago. Updated about 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
09/30/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
613

Description

When Morpho is displaying a package, several of the menus that work for the
result set window should also work for the package. These include the
synchronize, delete, and export menus. Need to verify that each of these menus
is active when a data package window is open, and to make sure they work
properly. Fix them if they don't.

History

#1 Updated by Jing Tao about 17 years ago

  • Bug 422 has been marked as a duplicate of this bug. ***

#2 Updated by Jing Tao about 17 years ago

Now synchronize, delete, export and openPreviousVersion menu worked well in
data pakcage frame too.

Now MorphoFrame are divied tow parts: search result and data package. From
them we can get tow different Objects: ResultPanel and DataViewContainerPanel.
From these panels, we can get information such as selected docid,
location(local or network) and so on. The information can be passed to
DataPackageInterface to do synchroinze, delete, export and open previouse
version. The above procedures were finished in different Command classes.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 613

Also available in: Atom PDF