Project

General

Profile

Bug #6365

'Maximum call stack size exceeded' error

Added by Lauren Walker almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

History

#1 Updated by Lauren Walker over 7 years ago

  • Target version set to 1.4.3

#2 Updated by Lauren Walker over 7 years ago

  • Subject changed from Map does not render when user enters a search term multiple times very quickly to 'Maximum call stack size exceeded' error

#3 Updated by Lauren Walker over 7 years ago

I believe this is being caused by the setInterval in the DataCatalogView addAll function, which checks if the map is ready before adding the result rows 26+

#4 Updated by Lauren Walker over 7 years ago

  • Target version changed from 1.4.3 to 1.4.4

I believe this error is caused by the same infinite loop that was freezing up metacatui in 1.4.1, which has since been fixed. However, I am keeping the ticket around in case the error pops up again sometime soon.

#5 Updated by Lauren Walker over 7 years ago

  • Status changed from New to Resolved

After some testing and attempts to recreate this error, it looks like it has been resolved as it was the same infinite loop that was freezing up the application.

Also available in: Atom PDF