Project

General

Profile

Bug #6584

bug in validity of personnel element

Added by Matt Jones almost 5 years ago. Updated almost 5 years ago.

Status:
New
Priority:
High
Assignee:
Category:
morpho - general
Target version:
-
Start date:
08/12/2014
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

I got a report from Zach Hoyt about having trouble uploading a document from Morpho to the KNB. In looking at the document, it appears to have `references` keys in the personnel section that are not present as `id` fields in any creator or contacts in the document. So, it appears Morpho is creating invalid documents somehow. He says he is using Morpho 1.10.2. Excerpts from the conversation are below, and the file produced by Morpho is be attached.

Jing has already been interacting with this group on related issues in Morpho.

Also I am having a hard time saving this version to the network and don't know why.
I get an error; "Problems with saving to metacat in EML200DataPackage! The content of element 'personnel' is not complete." Any suggestions here?

I then tried to save a duplicate and it too failed. Maybe a KNB server issue so I will try again later.
I have tried to attach the current wraymond8.6 to this email as I can save it to my machine. Can you open this? The current version of this file should be wraymond8.6. You might have to add this to your \.morpho\profiles\ \data file. Let me know if this works? If it does could you load it onto the KNB server?

From: Zac Hoyt <>
Date: August 11, 2014, 7:34:50 PM PDT
To: Ginny Eckert <>
Subject: Re: Forage metadata

I downloaded the file wraymond8.6 from the KNB server. I then used Morpho to do all the editing. I then went to save and selected both Locally and Network. It appears to have saved locally to my machine just fine but I get the error when it attempts to save to the Network. Thanks for the help, Zac

On 8/11/2014 5:42 PM, Ginny Eckert wrote:
Talked with Matt and he's wondering how you generated that file. He says you deleted some parts but not others, so that's why you have a personnel error. Did you edit it outside of Morpho in a text editor? The fix is different depending on how you got there, so let me know and I'll get guidance.

Ginny

wraymond.8.6.xml (15 KB) wraymond.8.6.xml Example EML file with mismatched references Matt Jones, 08/12/2014 10:54 AM

History

#2 Updated by Matt Jones almost 5 years ago

  • Subject changed from bug in references for personnel element to bug in validity of personnel element

After looking more closely, it appears the references do match up. But there seems to be another validity issue. The EML Parser reports the following validation error:

cvc-complex-type.2.4.b: The content of element 'personnel' is not complete. It must match '(((((((((("":individualName)|("":organizationName))|("":positionName)){1-UNBOUNDED},("":address){0-UNBOUNDED}),("":phone){0-UNBOUNDED}),("":electronicMailAddress){0-UNBOUNDED}),("":onlineUrl){0-UNBOUNDED}),("":userId){0-UNBOUNDED})|("":references)),("":role){1-UNBOUNDED})'.

#3 Updated by Jing Tao almost 5 years ago

The problem is in this section:
<personnel id="1406745330857">
<individualName>
<givenName>Allison</givenName>
<surName>Rice</surName>
</individualName>
<organizationName>University of Alaska-Fairbanks</organizationName>
<electronicMailAddress></electronicMailAddress>
</personnel>

It misses the required element "role". If I add it, it works:

<personnel id="1406745330857">
<individualName>
<givenName>Allison</givenName>
<surName>Rice</surName>
</individualName>
<organizationName>University of Alaska-Fairbanks</organizationName>
<positionName>researcher</positionName>
<electronicMailAddress></electronicMailAddress>
<role>co-Principal Investigato</role>
</personnel>

I am going to take a look why morpho doesn't enforce user to fill the element.

#4 Updated by Jing Tao almost 5 years ago

I asked Zach how the entry was created and Zach couldn't remember.

I can't reproduce bug (I tried all of roles) . I also looked at the code and i didn't see the obvious bug.

I helped Zach to fix the issue.

Also available in: Atom PDF