Project

General

Profile

Bug #6623

Metacat compilation should target Java 1.6

Added by Jing Tao about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
11/13/2014
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

see :https://redmine.dataone.org/issues/6529

History

#1 Updated by Jing Tao about 5 years ago

  • Status changed from New to Closed

I built metacat.war, index-war on java 7. Then i ran it on java 6. it works fine.

#2 Updated by Jing Tao about 5 years ago

  • Status changed from Closed to In Progress

Metacat-index component doesn't work with java 1.6:

[ERROR]: Application.run Error loading class [org.dataone.cn.indexer.parser.MergeSolrField] for bean with name 'eml.abstract' defined in class path resource [application-context-eml-base.xml]: problem with class file or dependent class; nested exception is java.lang.UnsupportedClassVersionError: org/dataone/cn/indexer/parser/MergeSolrField : Unsupported major.minor version 51.0 (unable to load class org.dataone.cn.indexer.parser.MergeSolrField) [edu.ucsb.nceas.metacat.index.ApplicationController]

#3 Updated by Jing Tao about 5 years ago

  • Status changed from In Progress to Closed

Ben and I installed the 2_4_2_RC2 binary files, which were built on Jenkins, on mn-sandbox-unm-1.test.dataone.org which is running java 1.6. It works for both of us.

Also available in: Atom PDF