Project

General

Profile

Actions

Feature #6825

closed

Add download attribute to download button to force download on most browsers

Added by Lauren Walker over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
07/28/2015
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

In metadata page download contents table.


Related issues

Related to MetacatUI - Support #6809: UX Testing ResultsResolvedLauren Walker07/27/2015

Actions
Actions #1

Updated by Lauren Walker over 7 years ago

  • Status changed from New to Resolved

The download attribute was already being used in all Download buttons. The issue is that only a small number of browser versions support it (Safari and IE don't at all).Firefox only supports it on links to the same origin.

I added a value to the download attribute that matches the name of the entity from the metadata. If/when browsers support this HTML5 feature, that name will be used as a suggested file name in the "save as" dialog.

I also added the target="_blank" attribute so that users who are not using modern FF or Chrome will have the file open in a new tab.

Actions

Also available in: Atom PDF