Project

General

Profile

Bug #6890

search.test.dataone.org proxy not handling orcid.org accounts

Added by ben leinfelder almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

When viewing an http://orcid.org account on the profile page, there is an error looking up the account details.

https://search.test.dataone.org/#profile/http://sandbox.orcid.org/0000-0003-2650-9537

I can call the cn-sandbox-2 endpoint successfully (directly):

https://cn-sandbox-2.test.dataone.org/cn/v2/accounts/http%3A%2F%2Fsandbox.orcid.org%2F0000-0003-2650-9537

But going though the search.test.dataone.org proxy results in the error.
https://search.test.dataone.org/cn/v2/accounts/http%3A%2F%2Fsandbox.orcid.org%2F0000-0003-2650-9537

History

#1 Updated by ben leinfelder almost 6 years ago

  • Assignee set to Lauren Walker
  • Description updated (diff)

#2 Updated by ben leinfelder almost 6 years ago

  • Status changed from New to In Progress

I was able to retrieve the account information from the search.test -> cn-sandbox-2 proxy by adding the "nocanon" option to the ProxyPass directive.

But now the profile page is not correctly parsing the subject. I see "Username: http:/" and "http:/ hasn't uploaded anything yet." in the profile UI.

#3 Updated by Lauren Walker almost 6 years ago

  • Status changed from In Progress to Resolved

This was caused by the app router cutting off the 'username' parameter after the first forward slash. I changed the router so that the profile paths will look like baseurl.com/#profile/username(/s=section/s=subsection)

Also available in: Atom PDF