Project

General

Profile

Bug #7149

Private metadata is indexed as isPublic=true

Added by Bryce Mecum about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
index
Target version:
Start date:
10/28/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

Jesse just pointed out this strange behavior to me. With Chrome, I get a "Failed -- Needs authorization" error in my download toolbar when I click the Download button on this metadata doc. I expected to be able to download the file this way and not to receive an error.

To reproduce:

- Log in to https://arcticdata.io/catalog
- Browse to https://arcticdata.io/catalog/#view/arctic-data.1580.1
- Click the "Download" button in the row for "Metadata: Passive acoustic data from A2 in the Bering Strait"
- Observe the download fails and that, at least in Chrome, you see a "Failed - Needs authorization" error

To check that this was a problem with MetacatUI instead of something else, I used my token and the R client to get sysmeta on the object (successful) and bytes (successful). So something's up.

History

#1 Updated by Lauren Walker about 3 years ago

Can you try reindexing that document? It is not a public metadata doc, but Solr still has isPublic=true, so the UI thinks it is public and displays it to the public user. (I would try reindexing it myself but I am not an admin on the arctic metacat for some reason)

#2 Updated by Lauren Walker about 3 years ago

  • Category set to index
  • Subject changed from Can't download metadata with Download button to Private metadata is indexed as isPublic=true
  • Project changed from MetacatUI to Metacat

I'm moving this ticket to metacat since this is an indexing problem, not a UI bug.

The metadata doc only gives readPermission to CN=arctic-data-admins,DC=dataone,DC=org and http://orcid.org/0000-0003-0039-5025. But it is indexed as isPublic=true.

#3 Updated by Jing Tao about 3 years ago

  • Target version set to 2.8.1
  • Assignee set to Jing Tao

#4 Updated by Jing Tao about 3 years ago

  • Status changed from New to In Progress

I believe this document was changed from public to private. Our solr merge mechanism had an issue:
https://projects.ecoinformatics.org/ecoinfo/issues/7156
It has been fixed. I will ask Bryce to index this document.

#5 Updated by Jing Tao about 3 years ago

  • Status changed from In Progress to Resolved

Bryce confirmed that the object was switched from public readable to private readable. Chris reindexed it ant it still is public readable.
So this bug relates to the fixed one:

https://projects.ecoinformatics.org/ecoinfo/issues/7156

Our solr index merge mechanism will merge existing system metadata fields back to the new solr doc which doesn't have the fields. See this case, the isPublic field doesn't exist in the new solr doc, but it does exist in the existing record in the solr server. So it merged this field back. The bug was fixed.

Also available in: Atom PDF