Project

General

Profile

Bug #716

Mechanism to add new plants:Insert business rules

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
userLoad
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
716

Description

Who? These pertain to irregular taxa


Related issues

Has duplicate VegBank - Bug #720: Party Perspective Managment (plant/comm):General interface to allowNew11/13/2002

History

#1 Updated by Robert Peet over 19 years ago

Mike has proposed:
1) at least one plant Status must be supplied for each plant Concept.
2) at least one plant Usage must be supplied for each plant Status.

I suggest the following revisions and additions

1) We should wire the system so that the default for the status is accepted by
the party creating the concept.

2) We should wire the system to have a default usage of the name used to
create the concept, and call this the scieintific name with authority system

This means that the required usage must be for the Scientific Name with
authority system, or we need to devise a hierarchy for reporting names when
the requested system is not populated. Seems like we will need a hierarchy for
reporting names when the usage is not provided for a requested system. For
example, if you ask for Sci name and it is missing, then you should get the
sci name with authors. I suggest the following hierarchies as business rules:

Scientific name w/authority (requested)
Scientific name w/o
English common name
Code

Scientific name w/o (requested)
Scientific name w/authority
English common name
Code

English common name (requested)
Scientific name w/o
Scientific name w/authority
Code

Code (requested)
Scientific name w/o
Scientific name w/authority
English common name

Do we need additional business rules?
I am having trouble thinking of any today. Here is the only one that comes to
mind, and it will require adding a field to the names table indicating that
the name is consistent with the IPNI list. What I would like is for all new
names added to be checked against the IPNI list by VegBank. This will require
that we either populate our names table with the perhaps one million names in
IPNI, or we store then as a separate table for validation purposes, or that we
use some as yet probably nonexistent web service from IPNI. I have just sent
an email to IPNI asking about these things, with copies to Mike, Gabe & Don.

#2 Updated by Robert Peet over 19 years ago

One additional business rule.

We should limit this activity to certified users. This would be level 2 and
higher.

#3 Updated by Michael Lee almost 19 years ago

can't load plants via web yet. This applies more to that situation. VegBranch
checks for rules before exporting to XML.

#4 Updated by Michael Lee over 17 years ago

fda

  • This bug has been marked as a duplicate of 720 ***

#5 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 716

Also available in: Atom PDF