Project

General

Profile

Bug #7161

Uploading a resource map with provenance data causes an NPE during indexing

Added by Peter Slaughter almost 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
index
Target version:
Start date:
11/22/2016
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:

Description

When uploading a resource map with provenance relationships included, indexing exits with an NPE during processing of RdfXmlSubprocessor:

Java.lang.NullPointerException
at org.dataone.cn.indexer.annotation.RdfXmlSubprocessor.getSolrDocs(RdfXmlSubprocessor.java:278)
at org.dataone.cn.indexer.annotation.RdfXmlSubprocessor.process(RdfXmlSubprocessor.java:265)
at org.dataone.cn.indexer.annotation.RdfXmlSubprocessor.processDocument(RdfXmlSubprocessor.java:119)
...

The problem appears to be caused by RdfXmlSubprocessor.getSolrDocs() calling httpService, which causes the NPE because an http solr server
is not run on metacat member node instances, which rely on the embedded solr server instead.

The included files are the resource map that was uploaded that caused the NPE, and a portion of the tomcat log file that includes
indexer TRACE info and the NPE.

urn-uuid-e029b6e4-be07-442b-a54e-2d0aca657294-resmap.xml (25.7 KB) urn-uuid-e029b6e4-be07-442b-a54e-2d0aca657294-resmap.xml Peter Slaughter, 11/22/2016 03:19 PM
bug.log (43.7 KB) bug.log Peter Slaughter, 11/22/2016 03:19 PM

History

#1 Updated by Jing Tao almost 4 years ago

  • Status changed from New to Resolved

Wrote a new MetacatRdfXmlSubprocessor which overwrites the code to access the solr http server directly. I also wrote a junit test class to test it and it worked well.

Also available in: Atom PDF