Project

General

Profile

Bug #754

Loader rectification tools: References

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
754

Description

Develop rules for rectification


Related issues

Is duplicate of VegBank - Bug #772: [663] :Loader rectification tools:Citations-bResolved11/13/2002

Is duplicate of VegBank - Bug #773: [666] :Loader rectification tools:Citations-cResolved11/13/2002

Blocks VegBank - Bug #748: Systematic approach to rectificationNew11/13/2002

History

#1 Updated by Robert Peet over 19 years ago

I am assuming here that "citations" is used to mean "References"

As with the plant and party rectification, there are two components to this
bug.

1) References in the data input stream need to be matched against the extant
references. A report needs to be generated. Then either the the user
overrides the validation layer and inserts, or enters via webform. I am
inclined to require the webform for version 1.01, and then consider midgration
to a more sophisticated rectification layer for 2.0. Either way, we do need
to be explicit about what uniquely identifies a reference so that this
information is properly embedded in the input stream. Mike might make a run
at this.

2) We also need a rectification capability embeddeed in the web form so that
the submitter can find close matches of fields like author, journal, etc.

I passs this on to ML for further review and revision before he passes this on
to Gabe for implementation.

#2 Updated by Michael Lee almost 19 years ago

  • Bug 772 has been marked as a duplicate of this bug. ***

#3 Updated by Michael Lee almost 19 years ago

  • Bug 773 has been marked as a duplicate of this bug. ***

#4 Updated by Michael Lee almost 18 years ago

this is part of a larger rectification piece that is almost entirely handled by
VegBranch

  • This bug has been marked as a duplicate of 748 ***

#5 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#6 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 754

Also available in: Atom PDF