Project

General

Profile

Bug #768

DTD publication - revision of DTD/XML to new format

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
768

Description

Status unclear;evaluation needed


Related issues

Has duplicate VegBank - Bug #740: New XML -- DESIGNResolved11/13/2002

History

#2 Updated by Michael Lee over 19 years ago

XML and DTD have been developed once, but need major revision and testing.

copying latest email from Bob to John:

1. Would be nice to view it as text in a browser. This works in
Netscape. Not sure why it does not with IE, but seems like a tiny problem
for someone to fix. I don't like clicking on a link and getting an error
message. At the same time, we need to publish the dtd on the VegBank
site where someone might find it.

The dtd is NOT an xml or html file, and should be really viewed in a text
editor, what I do is register the dtd file type with xmlspy -- I'll zip up
the dtd and put it anywhere on the website -- jsut let me know where.

Thanks. How about adding a link under "Database Architecture" on
http://vegbank.nceas.ucsb.edu/vegbank/general/info.html
and perhaps placing the dtd in the same folder or someplace nearby
(certainly on VegBank).

2. Is there a big difference between a new DTD and adding new
capabilities? Adding components to the DTD does not seem as likely to
break the system as rewriting the DTD.

This may be the case, you could change the dtd but the system would still
continue to compare the xml to the old/existing dtd.

So we sould reopen the bug with teh intent of adding capabilities
currently missing, but not redesigning what we have??

3. There are some components that need to be added at least in v 2, and
perhaps earlier. Stems will be needed for 2. Not sure how the system
can work at all without containing CoverMethod and CoverIndex; seem like
this is a critical difference between the design and implementation that
needs to be fixed. TaxonInterpretation seems nearly as essential.

Still need to know the answer to this one.

On Thu, 9 Jan 2003, John Harris wrote:

Hi,

The DTD is not intended to be viewed in the browser, but rather with a
text editor - if you want I can zip it up? This is an old xml definition
and I agree that it dues not exactly correspond to the database model
(which has had many and frequent changes), but it is critical to the
system and should will require many code changes to implement a new DTD.
I think that the bug to 'publish the DTD' has been fixed. John

On Thu, 9 Jan 2003, Robert K. Peet wrote:

We have some problems here.

1. You cannot view this on IE (though Netscape works)

2. It is incomplete in that a bunch of tables are missing. For example:
CommInterpretation
TaxonInterpretation
Citation
UserDefiuned
CoverMethod & COverIndex
Graphic
Stems
Note

3. One of us (myself, mike) needs to work through the whoel thing to
see if it covers that data model appropriately.

4. This all needs to be refined when the data model revisions for
citations, stems, and permissions come on line.

#3 Updated by Michael Lee about 19 years ago

Don't need a DTD as we have a schema, which is better anyway.

  • This bug has been marked as a duplicate of 740 ***

#4 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#5 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 768

Also available in: Atom PDF