Project

General

Profile

Bug #740

New XML -- DESIGN

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
740

Description

Are core attributes being loaded? - ML checks


Related issues

Is duplicate of VegBank - Bug #768: DTD publication - revision of DTD/XML to new formatResolved11/13/2002

Blocked by VegBank - Bug #739: QA for New XML (1.0.2) loading (Lee), then Fix errors in loading process (Farrell/Anderson)Resolved11/13/2002

Blocked by VegBank - Bug #870: New XML export and import into the VegBank systemResolved11/13/2002

Blocked by VegBank - Bug #726: Data loader plugins:VegBranch plots:Assess accuracyResolved11/13/2002

History

#1 Updated by Michael Lee over 19 years ago

we have all mentioned that the XML definition is incomplete and needs updating.
This is only superceded in priority by the data model changes.

For clarity of bugs, this bug will serve as stating that the new XML needs
designing.

#2 Updated by Michael Lee over 19 years ago

After all revisions of database schema.

#3 Updated by Michael Lee over 19 years ago

move these bugs down in priority as time is running out

#4 Updated by Michael Lee about 19 years ago

New XML has been designed and needs to be approved by PI's and developer.
Perhaps after working with it for a bit. I will attach a sample XML doc and the
XML schema that defines our candidate new XML document. This is based
directly on the XML doc that defines the database. So, changes in that will
result easily updated XML schemas to carry VegBank data.

#5 Updated by Michael Lee about 19 years ago

And example XML document containing data and the XML schema that validate
Vegbank Data XML can be found here:
http://tekka.nceas.ucsb.edu/~lee/xml/vegbank_exampleXML_schema.zip

(not attached as it is large and thus better compressed, which make attaching in
bugzilla more difficult)

#6 Updated by Michael Lee about 19 years ago

  • Bug 768 has been marked as a duplicate of this bug. ***

#7 Updated by Michael Lee about 19 years ago

fixed! Or alternate loading path.

#8 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#9 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 740

Also available in: Atom PDF