Project

General

Profile

Bug #803

Party entry and edit -- design / evaluate /connect and implement form

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
803

Description

JH


Related issues

Is duplicate of VegBank - Bug #784: [863] Party entry and edit -- design:reviewResolved11/13/2002

History

#1 Updated by Gabriel Farrell almost 22 years ago

This is fixed

#2 Updated by John Harris over 19 years ago

Bugs the require new feature to allow vb users to add information to the plots
database directly -- ie, not via adding a plot.

#3 Updated by Michael Lee over 19 years ago

This is a more commonly used bit of data that users will want to add outside of
a plot. Also somewhat simple in implementation -- simple form linked to one or
two tables. (A bit more for community -- but this functionality is quite
central to what we're working on.)

#4 Updated by Michael Lee over 19 years ago

current form development from MTL can be viewed at:
http://tekka.nceas.ucsb.edu/~lee/forms/

#5 Updated by Michael Lee over 19 years ago

Bob please evaluate the party forms on tekka in mtl's webspace as listed in
above comment and pass this bug to Gabe when/if you are satisfied with the
design of the form. If it needs revision, pass the bug back to michael

#6 Updated by Robert Peet over 19 years ago

Comments on the draft new “Party Form”
http://tekka.nceas.ucsb.edu/~lee/forms/party_add.html

Make field names closer to real English rather than being exactly equal to the
field names. Capitalize each.

salutation --> Salutation
givenName --> First name
middleName --> Middle name/initial
surname --> Last name
organizationName --> Organization
contactInstructions --> Contact Instructions

Make similar changes for the other fields.

Remove the option for owner. The owner is the registered user who creates the
party until the system administrator changes this.

Of course, Gabe will need to implement the permissions function that restricts
editing to the owner.

Let’s not require phone number

The line immediately after the add button needs some rewriting.

The click here for data dictionary is confusing because the user is not
directed to a specific table, and it is less than intuitive that three tables
must be examined. I suppose we should list all three and provide hotlinks to
each.

We need some business rules here. Ownership is by a registered user. We
currently track registered users as unique by email address. We do not
require email for a party (we do not always know an email). How do we link
registered users with parties? And, how do we affect the transfer of
ownership from a second-party creator to a registered user who wants to take
over his own party?

I suggest:

1. We move to primary key as the unique identifier for a registered user so
that email is no longer the unique identifier. Upon logging in the registered
user should be able to edit his/her email address, just like other user
attributes.

2. A new user when registering will create a new party by default. That user
can then send an email to the system manager requesting that one or more
extant parties be synonymized with the new party just created. This would
require that the manager reset part:currentName_ID to point at the user’s
party record. This also suggests a new function needed in the management
interface.

3. We remove or minimize the redundancy between the user registration table
and the party table. We don’t want name, organization, address, etc stored in
both places.

#7 Updated by Michael Lee over 19 years ago

  • Bug 784 has been marked as a duplicate of this bug. ***

#8 Updated by Michael Lee over 19 years ago

http://tekka.nceas.ucsb.edu/~lee/forms/party_add_3.html

Is now the new form that has renamed field labels, more explanations, hot-links
to datadictionary fields.

The other comments from Bob deal with a different bug, so I will copy them and
add them to bug 852. Starting with "We need some business rules here:"

If the form is good as is, then this bug should be passed to gabe for
implementation.

#9 Updated by Robert Peet over 19 years ago

The proposed form looks good, except that you need a pulldown menu for the
alternate identifier type.

#10 Updated by Michael Lee over 19 years ago

Alternate identifier type ? Is this the system? This is not a closed list, but
rather a system URL that the user owns that can uniquely identify the system
(always). See the data dictionary:
http://tekka.nceas.ucsb.edu/vegbank/dbdictionary/dd~table~referencealtident~field~system~type~tableview.html
Identifier is also not a closed list, as the user will select any name they want
for that.

Am I missing something? If it's good as is, then it should be passed to gabe
for implementation.

#11 Updated by Robert Peet over 19 years ago

Not sure what notes 8 & 9 refer to. ALternative identifier comments probably
pertain to the reference form rather than the party form, and in that case I
agree with Mike's assessment as to how they work, but there is still a
compelling need for the user of the reference form to be able to select from
alternatiav identifier types already in the system (or to add a new one).
Mike, perhaps you can shift this note over to the reference form bug, and then
forward the party form to Gabe for implementation.

#12 Updated by Michael Lee over 19 years ago

Party form seems ready to go. Other comments are about the reference form.

#13 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#14 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 803

Also available in: Atom PDF