Project

General

Profile

Bug #879

View a plot with simple URL

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
879

Description

JH implements


Related issues

Blocks VegBank - Bug #857: Evaluate: View a plot, quick viewResolved11/13/2002

Blocks VegBank - Bug #880: [1380] External browser query plot view ?Resolved11/13/2002

History

#1 Updated by John Harris over 19 years ago

No idea what this is?

#2 Updated by Michael Lee over 19 years ago

According to a Bob Email:

This is the capability to query the database via an http://vegbank.org/...
like string from a browser. I believe this bug depneds on Lee and Peet
indicating the critical fields to return. The bug may be in our court at
the moment.

#3 Updated by Michael Lee over 19 years ago

This bug depends on the simple plot view (bug 863) -- this form should be
sufficient for the results of the URL. The only other thing needed would be
connecting the URL to the query engine so that someone writes a paper and embeds
a hyperlink in their Paper:

"I sampled several plots and the only interesting one was Green River #5 Click
<a href="www.vegbank.org/show_plot_obs.cgi?vegbankaccession=blahblahblah.11Jan2003">
Here</a> to view the plot in VegBank's plot archive!"

#4 Updated by Michael Lee over 19 years ago

  • Bug 880 has been marked as a duplicate of this bug. ***

#5 Updated by Gabriel Farrell about 19 years ago

Allow a simple url to query an single plot
www.vegbank.org/vegbank/showPlot?accession=VB1232.11Jan2003

The accession number is
a) "Vegbank instance"
b) pk,
c) the date the plot was viewed.

There is a plan in the distant future to have several vegbanks so the initail
two char code does this.
The pk is straighforward
The date the plot was viewed is important as we want vegbank to be like a
publication, so on can see what the data looked like on an exact date in the
past. ( means rolling back changes made since the date before displaying the plot ).

The following url does the job now....

/vegbank/servlet/DataRequestServlet?requestDataFormatType=html&clientType=browser&requestDataType=vegPlot&resultType=summary&queryType=simple&plotId=125

#6 Updated by P. Anderson about 19 years ago

Users now have the ability to query plots using a simple URL that takes one of
the two following forms.

http://beta.nceas.ucsb.edu/plot/VB125.13jan2003
http://beta.nceas.ucsb.edu/plot/125

The number 125 in these examples is the PK (primary key) in the plots table.
Currently the VegBank instance, VB, and the date, 13jan2003, are ignored. For
this reason I made it so that a user simply needs to enter PK as in the second
example.

Note that the resultant page takes some time to generate. Also please note that
plot ID 125's dominant stratum is broad leaf herbaceous, my personal favorite.

#7 Updated by Gabriel Farrell almost 19 years ago

I confirm fix.

#8 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#9 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 879

Also available in: Atom PDF