Project

General

Profile

Bug #987

jlCommandProxy doPost() should check inputs for null values

Added by Matthew Brooke over 16 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
jalama-general
Target version:
Start date:
02/12/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
987

Description

Currently, if you pass a null as the "parameters" arg for doPost(), the app
crashes.

History

#1 Updated by Matthew Brooke over 18 years ago

still having probs - which I think are attributable to this bug. To see what
happens, run jalama data package wizard and hit the cancel button - dumps core
(on windowsXP)

The reason I think it's the null thing is this: previously, when finish pressed,
the same thing would happen, so I changed the doPost() call to pass a dummy
string parameter instead of passing null, and it then worked OK.

NOTE - this checking for null should happen in both directions - i.e. data
posted from the xul to the xpcom, and also data coming back from Jalama java
classes to xpcom (ie the return values). Some Command objects may return null
instead of a Map

#2 Updated by Matthew Brooke over 18 years ago

OK - here's the scoop...

The problem is not with passing null values into jlCommandProxy.doPost() -

The core dump occurs only when passing null values back to the XPCOM stuff
FROM JALAMA - for example when a Command object returns null instead of a Map.
Therefore, we should check for and handle this occurrence gracefully, since it
should be valid and possible, when writing a Command object, to have it return
null.

(for example - look at lines 58 to 64 of finalize_Command.java - when returning
null, get a core dump, but when returning a dummy Map, works OK)

This crash could be happening either within jlCommandProxy or jlJVMRegistry -
don't know which.

#3 Updated by John Harris over 16 years ago

No more crashes when a null paramater string is passed to the jalama app.

#4 Updated by John Harris over 16 years ago

This is now fixed

#5 Updated by John Harris over 14 years ago

We are no longer using webclient so this bug is no longer relevant.

#6 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 987

Also available in: Atom PDF