Project

General

Profile

Actions

Bug #1169

closed

Upgrade VegBranch to new 1.0.2 Vegbank data model

Added by Michael Lee almost 21 years ago. Updated over 19 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
vegbranch
Target version:
Start date:
10/02/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1169

Description

mirror Vegbank in changing of stems model (new fields to taxonInterpretation)
and irregular taxa (taxonObs.plantName_ID -> plantName and recursive key to
taxonInterpretation for multiple concepts as part of the same interpretation).
This also involves changes to the loading process in VegBranch.


Related issues

Is duplicate of VegBank - Bug #765: [705] :Complete ACCESS tool for input:test and evaluate VegBranchResolvedRobert Peet11/13/2002

Actions
Blocks VegBank - Bug #1079: Revise DB model to better deal with idiosyncratic taxaResolvedP. Anderson05/29/2003

Actions
Blocks VegBank - Bug #786: Update the Plots datamodel to allow for individual treesResolvedMichael Lee11/13/2002

Actions
Blocks VegBank - Bug #1219: VegBank 1.0.2 model - implementedResolvedP. Anderson11/21/2003

Actions
Blocks VegBank - Bug #1218: Get really new XML importing (version 1.0.2), allow zippedResolvedGabriel Farrell11/21/2003

Actions
Blocked by VegBank - Bug #699: Copy Plants (and anything else) directly from VegBank to VegBranch for release 1.0.0ResolvedMichael Lee11/13/2002

Actions
Actions #1

Updated by Michael Lee almost 21 years ago

http://tekka.nceas.ucsb.edu/~lee/vegbranch/2003-10-15/

contains the laterst version of VegBranch:
exportForm_irregTaxaFix_VegBranch.zip

This needs to be QA/QC by Lee Anne and Michael. Errors in the database can be
posted to this bug.

Actions #2

Updated by Michael Lee over 20 years ago

  • Bug 765 has been marked as a duplicate of this bug. ***
Actions #3

Updated by Michael Lee over 20 years ago

model changes mean VegBranch changes. Need to perhaps have a list for VegBranch
updates, as users "out there" with VegBranch may want to know when it has been
updated, even if they don't want to be on the list, for help.

Actions #4

Updated by Michael Lee over 20 years ago

VegBranch release candidate 1.0.2 is out. See Michael Lee for URL if you want
it. Lee Anne is doing some additional tests on it and Michael will finish up
any more work to be done with it the last week of January and get it to Tim Howard.

Actions #5

Updated by Michael Lee over 20 years ago

VegBranch 1.0.2 is ready to go from a functionality point of view. Need to get
attached data (plants, etc.) from a real version of vegbank so that
rectification becomes a non-issue (plants, etc. will be recognized from matched
accession codes). That is captured in bug 699.

Actions #6

Updated by Michael Lee over 20 years ago

VegBranch now capable of zipping XML files, if the machine VegBranch is on has
WinZip. There is some configuring needed, to make sure VegBranch knows where
WinZip32.exe is, but once that's one, it's one button click-zipping. XML upload
also now supports zipping, so it's a nice combination.

Users can also zip the files themselves, if they like, of course.

Actions #7

Updated by Michael Lee over 20 years ago

done! on vegbank.org

Actions #8

Updated by Redmine Admin over 11 years ago

Original Bugzilla ID was 1169

Actions

Also available in: Atom PDF