Project

General

Profile

Bug #1209

Add functionality to EML 2 stylesheets written by Jing so that they can be used by Morpho and make other changes

Added by Saurabh Garg over 15 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
11/17/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1209

Description

Two tasks to be done here..
1. First is to fix the stylesheets so that view in Java Browser is correctly
rendered. The columns inside tables don't lineup correctly currently.
2. The second change is to add functionality to eml2 so that they take
parameters for returning html with descriptions of entities and attributes.
This is required for viewing entity and attribute details inside Morpho.


Related issues

Is duplicate of Morpho - Bug #1285: Email and Web hotlinks in Data Package Documention do not workResolved01/23/2004

History

#1 Updated by Saurabh Garg over 15 years ago

From Bug# 1243

Access rule for "public" is not showing up properly in the metadata display
screens or the exported metadata.html file. Probably a problem in the xslt.

#2 Updated by Saurabh Garg over 15 years ago

From bug # 1285:

If user double clicks on the email address or Web site link within a Data Set
Description component (e.g., Prinicpal Investigator or Asssociated Party),
the link does not resolve to an email program or Web site.

------- Additional Comment #1 From Saurabh Garg 2004-01-30 10:42 -------

This change needs to be made in XSL. So that no links are shown in Morpho.

#3 Updated by Saurabh Garg over 15 years ago

  • Bug 1285 has been marked as a duplicate of this bug. ***

#4 Updated by Saurabh Garg over 15 years ago

The stylesheets work fine for Morpho now. I am changing target milestone to v1.6
Thing left to do is to check if same set of stylesheets can be used by both
Metacat and Morpho.

#5 Updated by Saurabh Garg about 14 years ago

Closing this bug as same stylesheets have been used by both Morpho and Metacat
since last Morpho release.

#6 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1209

Also available in: Atom PDF