Project

General

Profile

Bug #1275

Comments on Text Import Wizard from Andrea Chadden

Added by Saurabh Garg over 16 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
01/23/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1275

Description

Reported in morpho-feedback-20040122.doc in /doc/devs/ by Andrea Chadden:

When selecting a numeric type for attributes (e.g., ordered, unordered), it is
sometimes difficult (even with the helpful examples) to select the appropriate
attribute type and standard unit for some common data types. Examples:
• Positive fractional numbers (0.1…3.12, 3.14..) with no negatives
allowed (as in length measurements).
• Positive integers >= 0, 1,… as in age or organism counts. Which
Standard Unit is appropriate? The closest Standard Unit I could find was ‘mole’.
• Are the numbers 3 and 3.44 both ‘counting numbers’?
Please provide more concrete examples of ‘relative’ vs. ’absolute’ attribute
types. A link to a short technical discussion would be good to have.


Related issues

Is duplicate of Morpho - Bug #1273: Comments about Text Import Wizard from Andrea ChaddenResolved01/23/2004

Is duplicate of Morpho - Bug #1274: Comments about Text Import Wizard from Andrea ChaddenResolved01/23/2004

History

#1 Updated by Saurabh Garg over 16 years ago

  • Bug 1274 has been marked as a duplicate of this bug. ***

#2 Updated by Saurabh Garg over 16 years ago

  • Bug 1273 has been marked as a duplicate of this bug. ***

#3 Updated by Saurabh Garg over 16 years ago

Reported in morpho-feedback-20040122.doc in /doc/devs/ by Rick Reeves:

When using Datapackage Wizard / New Data Table Wizard, and defining the
attributes or columns in the imported table: Neither the Absolute or Relative
data types provide a way to specify the units of monetary currency. Closest fit
seems to be ‘mole’ which is obviously incorrect. This error, in conjunction
with a similar error reported by Andrea, indicates that the selection of
attribute units needs some expansion. In addition, this section could use a
link to a concise description of the different measurement scales offered.

#4 Updated by Andrea Andrea over 16 years ago

The user guide now contains some discussion of numeric types, and could be
linked to this part of the dpw. It is located on the page of the user guide
called "Adding Data to a Data Package", about 1/3 of the way downn the page.

#5 Updated by ben leinfelder almost 11 years ago

There's extensive help on this topic available by clicking the "Help" button.
It seems as though this is more of a "documentation bug" and that it has more or less been addressed. There are likely some holes in the STMML unit dictionary, but you can define your own units ($) or go with the "dimensionless" fall back

#6 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 1275

Also available in: Atom PDF