Project

General

Profile

Bug #1418

MetacatUploadException when saving package

Added by Chad Berkley over 18 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
03/30/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1418

Description

I created a package with the wizard then attempted to save the package (both
locally and to the server) and I got an error: MetacatUpload Exception in
EML200DataPackage!
<error>
cvc-complex-type.2.4.a: Invalid content starting with element 'methods'. One
of '{"":access, "":dataTable,"":spatialRaster, "":spatialVector,"":storedProcedu
re,"":view, "":otherEntity}' is expected.
</error>

when i click ok, it displays the same error again, then i click ok it appears
to save the package locally, but not to metacat.

Here's the console log:

removed from window list
MetacatUpload Exeption in EML200DataPackage!

<error>
cvc-complex-type.2.4.a: Invalid content starting with element 'methods'. One of
'{"":access, "":dataTable, "":spatialRaster, "":spatialVector, "":storedProcedur
e, "":view, "":otherEntity}' is expected.
</error>

Problem Saving

<error>
cvc-complex-type.2.4.a: Invalid content starting with element 'methods'. One of
'{"":access, "":dataTable, "":spatialRaster, "":spatialVector, "":storedProcedur
e, "":view, "":otherEntity}' is expected.
</error>

History

#1 Updated by Chad Berkley over 18 years ago

It looks like the problem is that the methods element is being inserted out of
order in the document. The EML document morpho created had the following
order: contact, project, methods, access. The order in the schema is: contact,
methods, project, access.

#2 Updated by Saurabh Garg over 18 years ago

Fixed. Eralier, Method and Project screens were not being inserted in right
order.

#3 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1418

Also available in: Atom PDF