Project

General

Profile

Bug #1453

party editing screen popup hides wizard instructions

Added by Chad Berkley almost 17 years ago. Updated almost 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/05/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1453

Description

When you are cycling through the wizard and you get to the owner and contact
panels, the pary editing panel is automatically displayed. This is convenient
for people who know what to do already, but if it is your first time using the
wizard, the dialog hides the instructions on the wizard panel below so you don't
know what information you are supposed to be entering. I think the best
solution to this (at this point) is to stop the dialog from popping up
automatically.

History

#1 Updated by Matthew Brooke almost 17 years ago

I brought this up at a meeting, and thought we had decided to do as chad suggested (btu have slept
since then, so maybe I'm wrong :-)

Anyway, I agree with chad. Do we have a concensus? If so, it's an easy fix

#2 Updated by Dan Higgins almost 17 years ago

I disagree. It is so much, much easier for the user to have the party dialog
appear automatically than have to click Add every time. (QUESTION: Do we confuse
the first time user, or offend someone who has used Morpho several times?)

And I do not believe that the first time user really needs to see instructions
for filling out a simple name/address form.

An alternate solution might be to simply move the dialog's location down and to
the right so that the instructions on the summary page are visible in the
background. (Dan Higgins)

#3 Updated by Chad Berkley almost 17 years ago

And I do not believe that the first time user really needs to see instructions
for filling out a simple name/address form.

The problem is that you can't even see what type of person/org you are supposed
to be filling out, e.g. a contact, associated party or owner. Although I agree
that it is easier (very slightly) to have that popup, there still needs to be a
way to see who's address info you should be entering. I think that simpling
moving the dialog over so you can see what is under it is a very non-standard
way of doing that.

#4 Updated by Matthew Brooke almost 17 years ago

Removing one button click does make the flow marginally quicker - I wouldn't
agree with "much, much easier" though. The dialog appears only for the first
party on each page, and the user still needs to click "add" to enter more parties.

This small gain of removing one click has to be balanced against the undesirable
side effects, which are:
(a) user confusion (let's not under-estimate this - we've all seen the wizard
zillions of times, so it's second nature to us), and
(b) inconsistency with the remainder of the wizard and similar list-type dialogs
- which at best makes morpho seem badly designed, and at worst makes for more
user confusion.
c) Another potential source of confusion is that users may have several parties
to enter, but are presented with only a single-party dialog; they haven't yet
seen the original list that implies they can repeatedly add parties.

A problem with showing the dialog offset is that the current wizard screen fits
on our target minimum screen size (800x600). Moving the dialog outside this
outline will mean it's off-screen on 800x600 monitors (are there any left?? :-),
so would need moving by the user, thus negating any speed gains from the 1-click
reduction.

Suggested solutions:

1) not popping up the diaog, but having the keyboard focus placed on the "add"
button, so the "power users" can just hit enter to open the dialog

2) not popping up the dialog the first time the wizard is run, but popping it up
on subsequent runs? (save a flag in the config). Not too keen on this one, but
like it better than always popping up the dialog.

Any other suggestions?

#5 Updated by Matt Jones almost 17 years ago

I like your solution #1 -- placing focus on the Add button. However, keep in
mind that the screen resolution limits are just the minimums. If we detect that
a user has a higher res screen, it is certainly legit to adjust our window
placement algorithms to allow the user to see appropriate parts of the
background screen if it doesn't end up being ackward. But, in this case I think
that it is better to not bring up the dialog automatically because of the loss
of context that occurs by doing so.

#6 Updated by Matthew Brooke almost 17 years ago

implemented solution #1 -- placing focus on the Add button

#7 Updated by Redmine Admin almost 8 years ago

Original Bugzilla ID was 1453

Also available in: Atom PDF