Project

General

Profile

Bug #1531

Import local eml documents to create new data packages

Added by Saurabh Garg over 15 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
04/22/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1531

Description

Add support for importing local eml documents to create new data packages,
along with tabular data they describe (ideally validating data via the metadata
and/or validating the attribute metadata based on the new data)

Relevant part from Wade Sheldon's email....

"The only "problems" I had with the program were really ones of scope related
to using it within the context of an existing IM program in LTER or elsewhere
(the same issues I discussed with Chris and Chad years ago in Phoenix). Unless
I missed something big, your approach to working with metadata using Morpho
only allows two avenues for loading metadata documents: a) manual creation of
data packages de novo using forms and wizards, b) retrieval of existing
packages from Metacat. Because Morpho doesn't appear to offer any mechanism for
importing local metadata documents (i.e. eml files) in whole or in part, or
copying existing packages for editing and re-use for repeat submissions (i.e.
boilerplating or templating), there is no mechanism for coupling Morpho with
existing information systems or recouping effort already spent entering
metadata for long-term monitoring data sets (for which only temporal coverage,
abstract and title may have changed since the last submission).

I view this as a large impediment that may preclude use of Morpho in many IM
shops, at least for initial metadata entry and editing. In order to create
metadata more efficiently, many IMs will be forced to generate eml metadata for
new data sets via some other path that supports content re-use (e.g. raw xml
editing or generation from an RDBMS using scripting) and then load them into
Metacat via Harvester or another channel. This will limit use of Morpho to
metadata viewing/polishing and Metacat querying, which is a shame considering
all it has to offer users."


Related issues

Has duplicate Morpho - Bug #1847: import EML documents into MorphoResolved12/21/2004

History

#1 Updated by Veronique Connolly over 14 years ago

Duplicate of bug #1847

  • This bug has been marked as a duplicate of 1847 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1531

Also available in: Atom PDF