Project

General

Profile

Bug #1847

import EML documents into Morpho

Added by Veronique Connolly over 15 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
12/21/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1847

Description

We need to implement a feature that allows the import of EML documents and
tabular data associated with these documents. The import step would include
validation to ensure that the document is a valid EML document. The docid of the
imported document would be compared to the docids of local data packages. If a
similar docid is found, Morpho would ask whether the user wants to create a
revision of the existing dp or create a new dp. If no similar docid is found,
Morpho would automatically create a new dp (with a new docid).

This import feature would allow importing documents that have been created by
the current Export feature of Morpho. Currently, there is not a straightforward
way of opening in Morpho a data package created by the Export command (see bug
1793). When using the Export command, the document created should be saved in a
place where it will easily be retrieved when using the import feature.

On top of allowing the import of existing EML documents, the import feature
would allow users to have a "template" dp from which they would create new dps
that usually differ only slighty in their format. This would lessen the burden
of creating new dps from scratch.


Related issues

Is duplicate of Morpho - Bug #1531: Import local eml documents to create new data packagesResolved04/22/2004

Is duplicate of Morpho - Bug #1793: Can't open metadata file generated from "Export"Resolved12/01/2004

History

#1 Updated by Veronique Connolly over 15 years ago

  • Bug 1531 has been marked as a duplicate of this bug. ***

#2 Updated by Veronique Connolly over 15 years ago

Laura Downey's Morpho Usability Report (resulting from Feb. 2005 KNB workshop)
mentions this feature as a "future feature to strongly consider."

#3 Updated by Saurabh Garg almost 15 years ago

Added a new feature which makes a copy of the opened data package. Hence a data
package can be made and then used as a template to create similar datapackages.

This is not same as the import feature but would be useful for the users
requesting template like functionality.

#4 Updated by Will Tyburczy almost 14 years ago

  • Bug 1793 has been marked as a duplicate of this bug. ***

#5 Updated by Jing Tao over 10 years ago

During the import, if data file location is a remote one, we will do nothing. If it is in local file system, we should import it into morpho.

#6 Updated by Jing Tao over 10 years ago

Add a new menu - "import" into morpho. User can use it to import an eml document into morpho. For data file, the behavior will be as same as the above comment.

#7 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 1847

Also available in: Atom PDF