Project

General

Profile

Bug #155

revised UI for insert/update/delete to metacat

Added by Matt Jones over 19 years ago. Updated about 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
09/28/2000
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
155

Description

I think we need a revised user interface for inserting, updating, and deleting
metacat documents from within dmanclient. Insert and update should have very
natural interfaces that are only minor extensions of the 'Save as...' and
'Save' menu items, respectively. The current 'ID' assignment (from the
SaveToDatabase dialog) should be another field that parallels the filename field
in the Save As dialog. The 'ID Label' field in the SaveToDatabase dialog should
become a user-configurable preference, rather than something that is set for
every document individually. The 'Save As...' dialog should have a radio button
to choose whether to save locally or to the database (which enables/disables the
appropriate text entry fields).

This would mean eliminating the current 'Save to Database...' menu item and
dialog box. The 'delete' function from that dialog should become a menu choice
that is accessible from the querybean popup menu (right click on document in
resultset display, choose 'Delete', get confirmation dialog). The 'File to
Submit' part of the dialog should be eliminated entirely (users should open a
document to make a change). The 'Access Control' part of that dialog should
become a separate dialog that the user can open from the 'Save as...' dialog box
and by selecting a menu item from the querybean resultset context popup menu.


Related issues

Has duplicate Morpho - Bug #208: new DataPackage handling componentResolved04/09/2001

History

#1 Updated by Matt Jones over 19 years ago

Changed the milstone to Beta2.

#2 Updated by Matt Jones about 19 years ago

Functionality subsumed under bug 208, the redesign of the data package module.

  • This bug has been marked as a duplicate of 208 ***

#3 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 155

Also available in: Atom PDF