Project

General

Profile

Bug #208

new DataPackage handling component

Added by Matt Jones over 19 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/09/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
208

Description

Need a new data package componenet from Morpho. This component represents a
resource (in the EML sense), and most importantly, a "dataset resource"). Thus,
it has mechanisms for storing all of the state info regarding a dataset, can
access the client-framework to read/write parts of the dataset locally and to
the metacat, and has a easy-to-understand mechanism for viewing a dataset in a
window (which it should register with the framework). This should be
implemented as a Morpho plugin, so it needs to implement all of the plugin
interface methods. Chad is taking the lead on this, with assistance from Dan.


Related issues

Is duplicate of Morpho - Bug #87: need ability to upload data with metadataResolved08/20/2000

Is duplicate of Morpho - Bug #155: revised UI for insert/update/delete to metacatResolved09/28/2000

Blocked by Morpho - Bug #209: New DataPackage WizardResolved04/09/2001

Blocked by Morpho - Bug #214: Redesign query pluginResolved04/09/2001

History

#1 Updated by Matt Jones over 19 years ago

  • Bug 155 has been marked as a duplicate of this bug. ***

#2 Updated by Matt Jones over 19 years ago

  • Bug 87 has been marked as a duplicate of this bug. ***

#3 Updated by Chad Berkley about 19 years ago

mostly done

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 208

Also available in: Atom PDF