Project

General

Profile

Bug #1712

Radio buttons for choice are "all" set as default in Tree Editor

Added by Mark Servilla almost 15 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
10/08/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1712

Description

When creating a new instance document, the Tree Editor sets all radio buttons as
the default. If the document is saved without deselecting all but the desired
radio button ("schema choice"), all choice elements are saved - which, results
in an invalid EML document.

Note that this behavior is not verified for all choice sections within the Tree
Editor.


Related issues

Is duplicate of Morpho - Bug #1701: All choices selected by default in tree editorResolved09/28/2004

History

#1 Updated by Andrea Andrea over 14 years ago

  • Bug 1701 has been marked as a duplicate of this bug. ***

#2 Updated by Saurabh Garg over 14 years ago

Mark, I am not able to figure out a way to reproduce the bug. Can you please
add steps to the bug report on how to reproduce the bug. Thanks.

#3 Updated by Dan Higgins over 14 years ago

To find this bug, open a package in the tree editor and then click on the "Show
All" button. Then look for nodes named "(CHOICE)"

For example, find a dataset with attributes under the dataTable element (e.g.
the jscientist datapackage). There is a (CHOICE) node under the attributeList
element that is all selected radio buttons when the Show All button has been
clicked. These should NOT be radio buttons to begin with, and if they were, only
one should be selected.

Another example - The 'constaint' element follows 'attributeList'. It has a
(CHOICE) subelement which has a series of radio button elements, all of which
are selected.

Dan Higgins - May 2005

#4 Updated by Saurabh Garg about 14 years ago

Fixed.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1712

Also available in: Atom PDF