Project

General

Profile

Bug #2068

Error while building actor tree with PT CVS version

Added by Dan Higgins over 14 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
04/18/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2068

Description

If you are using the CVS version of Ptolemy (rather than 4.0.1 release), a
number of error message flash by when a new Kepler window is created. The error
message is something like:

java.lang.CloneNotSupportedException: Problem cloning 'startTrigger'

but if you look further at the output, you will see something like

[java] Caused by: ptolemy.kernel.util.IllegalActionException: Could not
find a port named 'startTrigger' or 'startTriggerPort'. This can occur when the
name of the variable does not match the name passed to the constructor of the actor.
[java] Right:
[java] startTrigger = new TypedIOPort(this, "startTrigger", true, false);
[java] Right:
[java] startTrigger = new TypedIOPort(this, "startTriggerPort", true,
false);
[java] Wrong:
[java] startTrigger = new TypedIOPort(this, "foo", true, false);
[java] in .configuration.actor library.Web Service

The problem is apparently that the variable name assigned to a new TypedIOPort
does not agree with the string name parameter ! i.e. in the GarpAlgorithm actor
the was a statement

public TypedIOPort cellSetFilename = new TypedIOPort(this, "cellSetFileName",
true, false);

Note that 'cellSetFilename'is not identical with "cellSetFileName" ('n' vs 'N')

If you change the string parameter to agree with the variabl name, the error
message disappears.

I don't know why this problem only appears with PTII/CVS. Something in the
introspection that builds the actor tree looks at the varible which does not
agree with the string name?

This is not just a problem with error output. Although Kepler will keep running,
any actor where this problem occurs will NOT be added to the tree!

History

#1 Updated by Dan Higgins over 14 years ago

Using the new Ptolemy release (5beta) fixes this problem.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2068

Also available in: Atom PDF