Project

General

Profile

Bug #2201

data not uploaded to metacat from morpho

Added by Matt Jones about 15 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
09/20/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2201

Description

Kristin Vanderbilt reports a problem with Morpho in which her two data tables
that were described in Morpho are not properly uploaded to metacat along with
her EML file (the EML file is sev.129.2). Morpho has the data files listed
using ecogrid urls as ecogrid://knb/SEV.4.1 and ecogrid://knb/SEV.5.1

I'm not sure how, but somehow the ecogrid URLs uses uppercase letters in the SEV
prefix, while the eml file uses lowercase. Kristin is unclear how this
happened, as am I. The file was uploaded from windows, which does not
differentiate case, which probably means that Morpho had difficulty creating the
"sev" and "SEV" subdirectories in her profile. So one possibility is to see
what would happen when the prefix is changed on windows to be all upper case.

History

#1 Updated by Matt Jones about 15 years ago

Targeting 1.7 because this bug has not yet been reproduced.

#2 Updated by Callie Bowdish over 12 years ago

Suzanne Lao with the Smithsonian Tropical Research Institute has been using Morpho to register data sets. She is having this same problem with being able to save the eml part of the data package but not the data tables part of the package. I noticed that she had an odd profile name lao_suzie. I think having this "_" in her profile name may of caused some of her problems. You can have a profile name that is different than the login name portion of the profile, but the special character may have caused a problem.

I was able to use Morpho to download her data package from metacat without the tables. She emailed the tables to me. I then created a lao profile using her network account login. Put the tables that she emailed me in the data directory and checked that the path was correct to them. I then made a slight change to the eml file and upload the data package. This worked for me but not for her.

I think there may be some problem in her .morpho profile area.

I think I have seen problems happen when people have a profile name with "special characters". We need to put some constraint on what people can use for their profile names. However I have noticed data packages from lter with the name knb-lter-der.749079.1 . Most of these data packages however do not include the data as a separate file but inline or have a link to another site.

We are trying to figure out why her data package did not upload the data tables.

I suggest moving the .morpho directory. Restart Morpho and creating a new profile with the network account that belongs to the data packages. Download the data package from the network. It will be stored in the new .morpho area. Then copy the data tables into the profile data area that the eml points to. In order to save the file to the network the version number for the eml part will need to change. A slight change and change back to the data package can do this. The data tables that never made it to the network can be the name of the data table (example 19.1) with the one being the first version to be saved up to the network.

There appears to be some record in Morpho of inserts that sometimes causes problems. I think this may be stored in the .morpho area and starting fresh may clean that up but the data is stored there too so that needs to be considered.

Users find the profile issues especially frustrating.

#3 Updated by Callie Bowdish over 12 years ago

I had Suzanne do all of the steps to create a fresh profile and then download the data package from the web and then upload the tables again (just like I did successfully). However all she was able to do was up the version of the eml file in the data package the data tables did not upload. I examined the differences between our two stderr.log (Morpho log file). She had this in her log file. I have taken out the http tags that were part of the message in the log file. I wonder if we are having problems with receiving data from long distance locations such a Panama.


Network Error (tcp_error)
A communication error occurred: "" 
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.
For assistance, contact your network support team.

Problem Saving unexpected error in edu.ucsb.nceas.morpho..datastore.MetacatDataStore.saveFile():

Network Error (tcp_error)

A communication error occurred: ""
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.

For assistance, contact your network support team.
---------------

#4 Updated by Callie Bowdish over 12 years ago

Marissa Bauer is having a similar problem where she is able to use Morpho to upload the metadata, including the table attribute information for a data package and save it locally. However, the data table does not save up to the network. When the data package is opened online or saved down to another computer the data table is missing.

I've looked at the stderr.log and what it looks like to me is that she waiting for a long time for it to update and then closes or "kills" Morpho.

Jing and I tried to have her duplicate the problem but were unable to see the error. We did not but the server logs on verbose but Jing did look at the log when she tried to save the file and he did not see any error.

Mark Schildhauer would like to see this problem resolved. We can not have data managers outside our network unable to upload data tables using Morpho. I've been going back and adding the tables for this situation, but this is not a permanent solution.

Callie

#5 Updated by Callie Bowdish over 12 years ago

Success with data table upload - Today I had Marissa create a new profile mbauer1 versus her older one mbauer. My directions were: Maybe make your name mbauer1. Then when you fill out the profile form be sure and use your same network login:
mbauer organization: NCEAS and use mbauer1 as your Data Package
Identification. First time saving she was unable to login because the profile had unaffiliated for the organization. The organization part needs to be emphasized.

After we edited her profile mbauer1.xml to change the organization to NCEAS she was able to login and save the data table (Excel file).

This seems to have fixed Marissa's problem but she had different errors than Suzanne.

#6 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2201

Also available in: Atom PDF