Project

General

Profile

Bug #2238

Show all in tree editor not revealing sub-elements in Linux or OSX

Added by Will Tyburczy over 15 years ago. Updated almost 15 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
11/02/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2238

Description

To recreate this bug:
-Open a dp
-Open the tree editor for the dp
-Click "Show all"
-Click on an element that wasn't in the dp (publisher is usually a safe choice
for this)

None of the sub-elements of that element will be displayed, making the element
appear to be a leaf node. This effectively prevents user's from adding new
elements to the dp using the tree wizard, as they can't fill in values for
required sub-elements.

Note that this is only occurring on Mac OSX and Linux. The Windows version
seems to be working properly.


Related issues

Blocked by Morpho - Bug #2042: Failure when using dataTable, spatialRaster, and spatialVector in tree editorIn Progress03/11/2005

History

#1 Updated by Veronique Connolly over 15 years ago

I'm getting the same thing on Windows. Also, the elements of the "project"
module don't show up when you click on "show all". In theory, a CHOICE node
should appear under which the following elements would be found (under
SEQUENCE): title, personnel, abstract, funding, studyAreaDescription,
designDescription, relatedProject.

#2 Updated by Jing Tao almost 15 years ago

for windows, 1.6.0 release doesn't work. but 1.5.1 works.
for linux, neither 1.6.0 nor 1.5.1 works.

#3 Updated by Jing Tao almost 15 years ago

The problem was caused by inserting a clone a new tree node and cloned node doesn't have information about children. If we changed back to use node itself rather than cloned node, it will cause another problem - if eml document has two duplicate node, the second couldn't show subtree.

I tried to deep copy a node rather than clone a node in new approach. It can resolve the problem, but performance is very poor. So I add condition that only deep copy duplicate node, now it get better performance.

#4 Updated by Redmine Admin about 8 years ago

Original Bugzilla ID was 2238

Also available in: Atom PDF