Project

General

Profile

Bug #2042

Failure when using dataTable, spatialRaster, and spatialVector in tree editor

Added by Veronique Connolly over 15 years ago. Updated over 10 years ago.

Status:
In Progress
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
03/11/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2042

Description

Creating metadata using the dataTable, spatialRaster, and spatialVector modules
in the Morpho Editor results in an error message and a lost of the information
entered in the editor:

I created a simple data package in Morpho using the DPWizard (I only filled in
the required fields). Then I opened the tree editor. I clicked on “Show All”
and then expanded the dataTable module and entered info for the required fields.
I made sure only one SEQUENCE radio button was selected whenever there was a
CHOICE (see bug #1712). I clicked on “Trim” and then made sure the
spatialRaster and spatialVector boxes were not checked. I clicked OK on the
Morpho editor. I got the following message:

"The saved document is not valid EML2 for some reason. You can save it
locally and fix the problem later, but you will be unable to submit it
to the network storage system. Do you want to Continue Exiting the Editor?"

I clicked Yes to that message and then got a message saying "physicalList null"
message. I then clicked OK (it takes 4 clicks) to that message and got another
error message: “Exception in converting edited XML to DOM!null.”

After I clicked OK for this last message, the dp window was grey (empty) and the
butterfly continuously beat its wings, and I had to close the dp. The info I
entered in the tree editor was lost. I had saved the dp before I went into the
tree editor, but if you don't, you also loose what you had entered in the DPW.

Laura Downey discovered this bug using the spatialRaster module. I tried
replicating what I described above using the spatialRaster module and got the
same result (I made sure the dataTable and spatialVector boxes were not
selected): error messages and lost of info.

I also tried this with the spatialVector, got the first message mentioned above,
and then got a message saying “Unable to display this data. However, an empty
table with the column header information will be shown.” The info I entered in
the editor was then displayed in the data package (data table and table
documentation panels). However, this only happened once. After that time, I
repeated this process several times in the spatialVector (trying to repeat what
I did the first time) and got the same error messages and lost of info described
above for the dataTable and spatialRaster modules.


Related issues

Blocks Morpho - Bug #2238: Show all in tree editor not revealing sub-elements in Linux or OSXResolved11/02/2005

History

#1 Updated by Veronique Connolly over 15 years ago

This is from e-mails Laura Downey sent me after discovering the bug in the
spatialRaster module:

"Once i started working on the spatial raster module, i wasn't able to save any
information, because i got an error that said physicalList null. I tried
different times and i got the same error over and over again. physicalList looks
like it's the name of a node and i tried looking for it, but i wasn't able to
find it.

Then i tried creating a new very basic data package just with the required
fields (to minimize possible errors) and then i went on to work on the spatial
raster module making sure all the required fields were filled in. However i got
the same error again.

We also tried to see if a temporary file of the data package was available so
that we wouldn't loose the information we imputed in the spatial raster module,
but we couldn't find one. Do you have any idea why this keeps hapenning? How can
we avoid that error and be able to save the information on that module? I know
that module is not required, but for the data we are managing it's very
important that we include the spatial raster information.

I tried filling all the required fields and selecting only one radio button
whenthere is a choice, however i keep getting the same error. We are very
interested in transferring all of our data to EML, but as long as we are not
able to use the spatial rference module, we won't be able to transfer ur data
since the spatial component of our data is very important."

#2 Updated by P. Anderson over 14 years ago

Will and I think that this bug depends on bug 2238
(http://bugzilla.ecoinformatics.org/show_bug.cgi?id=2238).

#3 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2042

Also available in: Atom PDF