Project

General

Profile

Bug #2287

Saving local dp to the network creates dp with different docid

Added by Veronique Connolly almost 14 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
11/22/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2287

Description

I had two dps saved locally (connolly.259.8 and connolly.258.5). After I
proceeded to saving these dps to the network (knb metacat), the network icon
didn't appear, leading me to believe that my dps had not been saved. I searched
for them on the network and found them as connolly.259.1 and connolly.258.1, not
as connolly.259.8 and connolly.258.5.

History

#1 Updated by Veronique Connolly almost 14 years ago

This happened to me for three additional dps: connolly.287.1, connolly.281.1,
connolly.274.1.

#2 Updated by Callie Bowdish over 12 years ago

I experienced the same thing that Veronique reported using Morpho. This appears to only happen with data packages that have imported data tables. Save these data packages locally then make a change to them. Next time they are saved locally and to the network this error comes up in the Morpho stderr.log.

Name: action => update
Name: public => no
message from server:
<error>
Error in EMLSaxHandler.startElement UPDATE
</error>

MetacatUpload Exception in EML200DataPackage!

<error>
Error in EMLSaxHandler.startElement UPDATE
</error>

Problem Saving

<error>
Error in EMLSaxHandler.startElement UPDATE
</error>

This error does not occur with data packages that do not include an imported data table. I saved a few data packages locally, then made changes. Afterwards I saved again locally and to the network. ltderr.log reports that they update sucessfully. Morpho responds and updates correctly.
...
Name: action => update
Name: public => no
message from server:
<success>
<docid>bowdish.790.2</docid>
</success>

It takes two trys to update a data package with a table, when it has been saved locally first. The first time Morpho gets stuck and the error appears in the stderr.log.

#3 Updated by ben leinfelder over 9 years ago

Cannot reproduce with v1.8.0. Steps:
-Duplicate jscientist package
-Remove data table
-Import new sample data table
-save locally
-change title
-save locally (rev now 2)
-save to dev metacat
-local and remote have same docid/rev.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2287

Also available in: Atom PDF