Project

General

Profile

Bug #2309

File name conflict resolution when using same scope on different computers

Added by Will Tyburczy almost 15 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
12/06/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2309

Description

One example of the problem: I had a eml document adler.3.15, which happens not
to have had a .1 version saved on metacat. This document has data tables
adler.4.1, adler.5.1 adler.6.1 and adler.7.1. I download this from metacat onto
a second computer with a newly downloaded version of morpho. I edit this dp
using a profile that also uses the "adler" scope, and start importing new data
tables. The newly added tables come in as adler.1.1, adler2.1, adler.3.1, etc.
When I import the table that would be adler.4.1, everything seems fine until I
try to do a local save. The data table is not imported into the .morpho
directory because a adler.5.1 already exists. After saving, when I look at the
that table in morpho, the column headings and metadata for the new table are
correct, but the data in the table are those of the original adler.4.1 . Morpho
does not give any indication that the data from the newly imported table weren't
saved correctly.

There are other similar issues that seem to be cropping up from using the same
scope for files on different computers.


Related issues

Has duplicate Morpho - Bug #3454: Fixing docid conflicts in metacat or local fileResolved07/16/2008

Blocks Morpho - Bug #2360: Document Identifier Conflict ResolutionResolved02/16/2006

History

#1 Updated by Jing Tao about 12 years ago

duplicate to 3454 bug.

  • This bug has been marked as a duplicate of bug 3454 ***

#2 Updated by Jing Tao about 11 years ago

move to 1.7

#3 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2309

Also available in: Atom PDF