Project

General

Profile

Actions

Bug #2360

closed

Document Identifier Conflict Resolution

Added by Will Tyburczy almost 17 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Immediate
Category:
morpho - general
Target version:
Start date:
02/16/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2360

Description

Currently, Morpho uses the <scope> and <lastId> to generate the next document
id for any new document. When saving locally, if a document with this id already
exists, it will simply be overwritten silently. When saving to the network, the
save will generally fail silently. When there is a naming conflict like this,
the user should be alerted and given options for how to deal with the confict,
such as saving it with a higher revision number, saving it under a different
document id, etc.


Related issues

Has duplicate Morpho - Bug #3454: Fixing docid conflicts in metacat or local fileResolvedJing Tao07/16/2008

Actions
Blocked by Morpho - Bug #2285: Morpho creates a duplicate dp that has an existing docidResolvedSaurabh Garg11/22/2005

Actions
Blocked by Morpho - Bug #2309: File name conflict resolution when using same scope on different computersResolvedSaurabh Garg12/06/2005

Actions
Actions #1

Updated by Callie Bowdish over 14 years ago

My understanding is that previous versions of Morpho handle document conflicts. Judith worked with a previous version recently and didn't have the same problems as those working with the current version.

Actions #2

Updated by Callie Bowdish over 14 years ago

I tested previous version of Morpho 1.6.0 and found that it had problems with doc ids too.

Actions #3

Updated by Jing Tao over 14 years ago

it is duplicated to bug 3454

  • This bug has been marked as a duplicate of bug 3454 ***
Actions #4

Updated by Jing Tao over 13 years ago

move to 1.7

Actions #5

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 2360

Actions

Also available in: Atom PDF