Project

General

Profile

Bug #2346

Memory utilization on startup.

Added by Kevin Ruland over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
core
Target version:
Start date:
01/27/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2346

Description

Current CVS head of kepler (1-27-06): At welcome window, after forced gc,
memory usage is 57M. After one empty graph window, memory usage is 65M. After
opening second empty graph window, memory usage is 67M.

History

#1 Updated by Christopher Brooks over 13 years ago

Just some info, there was some traffic about this on 12/21/2005 in kepler-dev.

Basically, the problem is that Kepler opens up all the actors, which takes
time and memory, but has the added benefit of making it easier to search
the actors. In addition, this helps validate that all the actors
are present in the system.

Ptolemy does lazy loading, so everything starts up quickly with low
memory use. An additional advantage is that part of the configuration
can be invalid, say because of a missing package.
For testing purposes, we use the about:copyright mechanism to expand the
configuration. The really big disadvantage of lazy loading is that Ptolemy
does not have a search mechanism.

#2 Updated by Dan Higgins over 13 years ago

The current state of memory useage appears to be much 'better' (i.e. less memory
required) than was seen previously (see mem useage figures that are attached for
current version) and tests on 512Meg systems indicated no lack of memory problems.

We still may want 'lazy loading' at some point, but not really needed immediately.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2346

Also available in: Atom PDF