Project

General

Profile

Bug #2370

add query and display support for BDP/FGDC metadata

Added by Matt Jones over 14 years ago. Updated about 12 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
metacat
Target version:
Start date:
02/24/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2370

Description

Need to add support to query and display FGDC CSDGM metadata documents and NBII
BDP metadata documents.


Related issues

Has duplicate Metacat - Bug #3146: Include FGDC metadata in KNB and NCEAS skin search resultsResolved02/13/2008

History

#1 Updated by Matt Jones over 14 years ago

Initial support completed for the KNP skin in prep for the Kruger demo. BDP
documents can again be inserted into metacat. The KNP query form and browse
link now support the BDP returndoctype and returnfields, and the support for
these fields was added to the DocumentIdQuery class to support the spatial
queries too. The default resultset.xsl was modified to display the BDP
returnfields in the appropriate columns of the result set.

Still need to:
1) Make changes to other skins. Really should factor out these returnfield and
doctypes to a separate file that can be shared by all of the skins.
2) Redesign the NBII stylesheet to be consistent in style with the EML
stylesheet displays.
3) Figure out how the new returnfields affect which fields should be indexed by
default in the metacat.properties.

#2 Updated by Matthew Perry almost 14 years ago

An additional note: Since FGDC (and all non-EML documents) do not contain access constraints, there needs to be an easy way for users to describe the access rules.

#3 Updated by ben leinfelder about 12 years ago

while triaging for 1.9 release we determined that this has been resolved as of metacat 1.8.1
see bug 3146

  • This bug has been marked as a duplicate of bug 3146 ***

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2370

Also available in: Atom PDF