Project

General

Profile

Bug #3146

Include FGDC metadata in KNB and NCEAS skin search results

Added by ben leinfelder over 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
02/13/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3146

Description

Configure the searches for both the KNB and the NCEAS skin to return FGDC doctypes

This requires editing the pathquery such that the "metadata" doctype is included and also that the organizationName restriction is relaxed to include a placekey criteria for the FGDC metadata.

Each skin should also have a mapping for the FGDC doctype to an appropriate xsl for displaying the document.

Will likely need to copy and rework the existing FGDC xsl that is being used for sanparks/saeon.

(Something in the future might be to add the upload facility to the skins. But that will come at a later date - and in a different ticket if need be.)


Related issues

Is duplicate of Metacat - Bug #2370: add query and display support for BDP/FGDC metadataResolved02/24/2006

Blocks Metacat - Bug #3174: Metacat performance issue in Sanparks skinResolved03/13/2008

History

#1 Updated by ben leinfelder over 11 years ago

I have this working locally, but now that I think about it, it's on top of some other post-1.8.0 changes in metacat.
While the changes are mostly limited to the skins directory, there is at least one java code change (to prevent a null pointer exception).

I think all the changes do make metacat better, but they also introduce more potential for instability if deployed on KNB without being rigorously tested by many people.

Thoughts on the intended timeline for releasing this enhancement? (Is a 1.8.1 release feasible?)

#2 Updated by ben leinfelder over 11 years ago

For Zip file downloads (previously quite clunky when naming the files included in the zip) the following has been added to metacat:

Enable file naming when returning a zip file of the requested documents.
File names for each docid are provided as additional parameters named by the actual docid value that they are providing a name for. An example query string might look like:

action=read&docid=doc.1.1&docid=doc.2.1&qformat=zip&doc.1.1=fileName1.txt&doc.2.1=fileName2.jpg

and would create a zip file containing files named:
fileName1.txt
fileName2.jpg

This is enhancement was motivated by the SANParks/SAEON skin use of FGDC groups of files and will be useful in the NCEAS and KNB skins when they support FGDC metadata display and download.

#3 Updated by ben leinfelder over 11 years ago

I'd like to retarget this to 1.8.1 so that we don't need to back out any changes from the nceas skin.
An issue remains, however: the SANParks and SAEON skins have additional conditions in their pathqueries that limit the FGDC data returned by the "placekey" element in the FGDC schema. This more complex query seems to increase search time substantially. If we can resolve this issue in SANParks then it should not be an issue with the NCEAS skin. The KNB skin will not need to limit by the placekey because all data should be searched.

#4 Updated by ben leinfelder over 11 years ago

Made changes to the search/pathquery used in knbweb project and also added ability to display FGDC documents in the knb skin (metacat project).
Ended up tweaking the root fgdc stylesheet so that it looks decent in the knb skin.
Currently deploying on dev server so that it can be tested along with the nceas and sanparks skins that do the same searches

#5 Updated by ben leinfelder over 11 years ago

knbweb project is deployed on http://dev.nceas.ucsb.edu/
preliminary testing looks good (performance wise) but any additional testing on this "special skin" is greatly appreciated.

#6 Updated by ben leinfelder over 11 years ago

closing after conference call for 1.8.1rc2

#7 Updated by ben leinfelder about 11 years ago

  • Bug 2370 has been marked as a duplicate of this bug. ***

#8 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3146

Also available in: Atom PDF