Project

General

Profile

Bug #2389

Actor seach problem

Added by Dan Higgins about 13 years ago. Updated about 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
03/23/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2389

Description

Try seaching actor tree for 'Doc' or 'DocViewer'. Tree just 'flashes' and
returns to a single top level node. Seache for 'Docu' works!
(Observed on a Windows machine be Dan Higgins)

History

#1 Updated by Matthew Brooke about 13 years ago

This seems to be caused by DocViewer Parameter.

It appears in the tree with a "+" next to it, as if it is a folder rather than a leaf node. Clicking on the "+" briefly reveals a sub-level with the label "_hideName", and then the tree resets, as described above.

Searching for "doc" also causes this behavior, since the search display tries to show the _hideName subnode. Search for "docu" doesn't have this problem, because

If you then repeat either the clicks or the "doc" search a second time, the "_hideName" subnode shows up and the tree stays open.

See also Bug #2382, which has morphed into a the same thing as this. I'm requesting that this bug be retained for this specific issue, and Bug #2382 be re-diverted to address it's original purpose, which is a different issue from this one.

#2 Updated by Matthew Brooke about 13 years ago

made the _hideName attribute self-closing tag. previously, it surrounded the icon description, which i think was an error

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 2389

Also available in: Atom PDF