Project

General

Profile

Bug #2479

unable to validate eml.xsd and related schemas with XML*Spy and related suite of products

Added by John Cree over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
eml - general bugs
Target version:
Start date:
06/28/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2479

Description

As per question 10. in the FAQ's
"How can I get my existing metadata into EML?" ... "Case 3: If your metadata is already in XML but in some other form such as NBII or FGDC use the following conversion method..." The suggested method is to write an XSLT script to do the conversion. Although this may be possible, I am trying to save some time by using an Altova product (Mapforce) to do the conversion. It will essentially create the XSLT to do the conversion; however, it will only work with valid schema definitions or DTD's as input and output. There is no problem using the NBII DTD as input or output, however there are many errors when trying to validate the EML schemas. Is this a problem that has been observed by others that is occuring only with the validation done using Altova products, or is the problem with the eml schema definitions themselves?


Related issues

Has duplicate EML - Bug #2054: use of <any> in additionalMetadata is invalidResolved03/31/2005

History

#1 Updated by Matt Jones over 13 years ago

Yes, this is an existing, known issue that is currently being tracked in bug #2054. The EML schema is invalid, and causes problems in some external tools. It was not picked up early on because for some reason xerces does not detect the problem. There is a proposed solution in bug #2054, so I am marking this bug as a duplicate of that one.

The workaround for the time being until a new version of EML is released is to modify eml.xsd as described in bug #2054 in order to be able to proceed with your schema mapping activity.

Please continue any further discussion on this issue in bug #2054.

  • This bug has been marked as a duplicate of 2054 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2479

Also available in: Atom PDF