Project

General

Profile

Bug #2644

The edit feature in the NCEAS Data Repoistory does not work

Added by Callie Bowdish almost 14 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
11/06/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2644

Description

The edit feature in the NCEAS Data Repoistory does not work when logged in with a user name who has access to the document. A user submitted a data package using the online form at http://knb.ecoinformatics.org/cgi-bin/register-dataset.cgi?cfg=nceas. He was unable to edit it through the NCEAS Data Repository after submitting it successfully. It was confirmed by using both the nceasadmin login and his login. I used the same browser to login on the KNB site first and then went to the NCEAS Data Repository to search for the document. The document is searchable and visable with the Actions column on the webpage. The Actions column contains three buttons View, Edit, and Delete. The Edit button just gives a blank page when clicked. (here is the blank page address: http://knb.ecoinformatics.org/cgi-bin/register-dataset.cgi

I do not think this document had any editing done using Morpho. The test was done with nceas.301. However this document may be edited by Morpho in the near future.


Related issues

Is duplicate of Metacat - Bug #2806: Online Edit action for a data package brings up a blank pageResolved03/23/2007

Blocked by Metacat - Bug #3319: Edit feature doesn't work on documents with uneditable fieldsResolved05/23/2008

History

#1 Updated by Callie Bowdish over 13 years ago

  • Bug 2806 has been marked as a duplicate of this bug. ***

#2 Updated by Callie Bowdish over 13 years ago

http://knb.ecoinformatics.org/knb/style/skins/nrs/index.html - UCNRS and http://knb.ecoinformatics.org/knb/style/skins/obfs/index.html - OBFS both bring up blank pages when the edit button is chosen

I do not have any data sets submitted that come up with these organizations but it looks like they have the same problem

#3 Updated by Shaun Walbridge over 12 years ago

The crashing forms and keywords are fixed, the larger issues have been pushed into #3319. This is sufficiently fixed for the next point release of Metacat.

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2644

Also available in: Atom PDF