Project

General

Profile

Bug #2705

eml not valid is xmlSpy versions 2006+, eml-text and eml-documentation

Added by Margaret O'Brien over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
eml - general bugs
Target version:
Start date:
12/15/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2705

Description

This is NOT a duplicate of bug 2054.

These changes are needed to make eml validate in xmlSpy2006+:
eml-text.xsd:
<xs:complexType name="TextType"> => add mixed="true"
and to the choice of this complexType add minOccurs="0"

eml-documentation.xsd:
add elementFormDefault="qualified" to the root-element

History:
Some folks who have newer versions of xmlSpy (2006, 2007) were not able to validate eml documents. The failures are mysterious and variable. Validating eml.xsd is successful, but when validating a data package, Spy replies that the schema is invalid. It usually fails in eml-view, but also occasionally in eml-project, or eml-software.

Initially, Altova tech support said that it was a bug in Spy. They recently changed their tune, and suggested the above changes to our schema. With these changes, local copies of EML can now be validated in Spy2007. Altova did not quote the parts of the xml specification relating to this error. Given the error messages from Spy, I was not able to see where eml failed to comply with the xml specs. I have put the email trail with error messages at the url above, if that helps anyone else get to the bottom of this.

It could be that this xmlSpy behavior is still a defect in the software, and that eml schema is valid as is, and that tech support is just trying to shut me up.

Relationships to other bugs:
1. It's possible that this was part of the behavior that Inigo reported in bug #2479, or described in emails to eml-dev.
2. This is not related to bug 2054, in which eml.xsd failed due to the <any> element in additionalMetadata. That failure was noticed first in xmlSpy2005, whereas this behavior first appeared with Spy2006.


Related issues

Has duplicate EML - Bug #2703: eml not valid is xmlSpy versions 2006+, eml-text and eml-documentationResolved12/15/2006

History

#1 Updated by Margaret O'Brien over 13 years ago

Whoops - browser issues - same as 2073 and 2074

  • This bug has been marked as a duplicate of 2073 ***

#2 Updated by Margaret O'Brien over 13 years ago

listed as dupe of wrong dupe

#3 Updated by Margaret O'Brien over 13 years ago

same as 2703 and 2704

  • This bug has been marked as a duplicate of 2703 ***

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2705

Also available in: Atom PDF