Project

General

Profile

Bug #3083

Need sample CommandLine workflows for Windows

Added by Dan Higgins almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
documentation
Target version:
Start date:
01/22/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3083

Description

We need some simple examples of how to use the CommandLine actors especially for Windows systems. These should be in the Demos directory. They should be annotated so that typical non-programmer can understand how to use commandline applications to launch external applications within Kepler.

Dan Higgins - Jan 2008

History

#1 Updated by Dan Higgins almost 12 years ago

Two new example CommandLine workflows added to $KEPLER/demos/getting-started.

#2 Updated by Kirsten Menger-Anderson almost 12 years ago

I'm having trouble getting the CommandLine1 workflow to run on my PC/the latest nightly build (20081323). The workflow executes, and a display window opens, but it has no content. When I try to run HelloWorld from the command line, I get the following error: Exception in thread "main" java.lang.NoClassdefFound Error: HelloWorld.

#3 Updated by Dan Higgins almost 12 years ago

Works for me under Windows and MacOSX

#4 Updated by Dan Higgins almost 12 years ago

Discovered the the problem could be reproduced when kepler was launched from kepler.bat or kepler.sh. Using the command 'java -cp ./ HelloWorld solved the problem!

I suspect there is subtle issue of how env variable are inherited by subprocesses. it now seems to work OK with the classpath explicitly set in the commandLine string

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3083

Also available in: Atom PDF