Project

General

Profile

Bug #3110

Can't access actors via http

Added by Christopher Brooks over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
01/29/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3110

Description

ptolemy.kernel.util.IllegalActionException: Cannot find class: Waveform
Because:
-- ptolemy.eecs.berkeley.edu
-- XML file not found relative to classpath.
-- C:\cxh\src\kepler\http://ptolemy.eecs.berkeley.edu/xml/models/Waveform.xml
ptolemy.eecs.berkeley.edu
in file:/C:/cxh/ptII/build/classes/ptolemy/moml/demo/Networked/Networked.xml at line 153 and column 118
at ptolemy.moml.MoMLParser._createEntity(MoMLParser.java:3701)
at ptolemy.moml.MoMLParser.startElement(MoMLParser.java:2379)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:921)
at com.microstar.xml.XmlParser.parseContent(XmlParser.java:1104)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:924)
at com.microstar.xml.XmlParser.parseDocument(XmlParser.java:481)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:159)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1334)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1292)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1265)
at ptolemy.actor.gui.PtolemyEffigy$Factory.createEffigy(PtolemyEffigy.java:412)
at ptolemy.actor.gui.EffigyFactory.createEffigy(EffigyFactory.java:209)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:595)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:555)
at ptolemy.actor.gui.HTMLViewer.hyperlinkUpdate(HTMLViewer.java:264)
at javax.swing.JEditorPane.fireHyperlinkUpdate(JEditorPane.java:320)
at javax.swing.text.html.HTMLEditorKit$LinkController.activateLink(HTMLEditorKit.java:827)
at javax.swing.text.html.HTMLEditorKit$LinkController.mouseClicked(HTMLEditorKit.java:637)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:212)
at java.awt.Component.processMouseEvent(Component.java:5504)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5266)
at java.awt.Container.processEvent(Container.java:1966)
at java.awt.Component.dispatchEventImpl(Component.java:3968)
at java.awt.Container.dispatchEventImpl(Container.java:2024)
at java.awt.Component.dispatchEvent(Component.java:3803)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3901)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
at java.awt.Container.dispatchEventImpl(Container.java:2010)
at java.awt.Window.dispatchEventImpl(Window.java:1778)
at java.awt.Component.dispatchEvent(Component.java:3803)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Caused by: com.microstar.xml.XmlException: -- ptolemy.eecs.berkeley.edu
-- XML file not found relative to classpath.
-- C:\cxh\src\kepler\http://ptolemy.eecs.berkeley.edu/xml/models/Waveform.xml
ptolemy.eecs.berkeley.edu
in file:/C:/cxh/ptII/build/classes/ptolemy/moml/demo/Networked/Networked.xml at line 153 and column 118
at ptolemy.moml.MoMLParser.fileNameToURL(MoMLParser.java:1145)
at ptolemy.moml.MoMLParser._findOrParse(MoMLParser.java:4417)
at ptolemy.moml.MoMLParser._attemptToFindMoMLClass(MoMLParser.java:3498)
at ptolemy.moml.MoMLParser._createEntity(MoMLParser.java:3696)
... 38 more
Caused by: com.microstar.xml.XmlException: -- ptolemy.eecs.berkeley.edu
-- XML file not found relative to classpath.
-- C:\cxh\src\kepler\http://ptolemy.eecs.berkeley.edu/xml/models/Waveform.xml
ptolemy.eecs.berkeley.edu
in file:/C:/cxh/ptII/build/classes/ptolemy/moml/demo/Networked/Networked.xml at line 153 and column 118
at ptolemy.moml.MoMLParser.fileNameToURL(MoMLParser.java:1145)
at ptolemy.moml.MoMLParser._findOrParse(MoMLParser.java:4417)
at ptolemy.moml.MoMLParser._attemptToFindMoMLClass(MoMLParser.java:3498)
at ptolemy.moml.MoMLParser._createEntity(MoMLParser.java:3696)
at ptolemy.moml.MoMLParser.startElement(MoMLParser.java:2379)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:921)
at com.microstar.xml.XmlParser.parseContent(XmlParser.java:1104)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:924)
at com.microstar.xml.XmlParser.parseDocument(XmlParser.java:481)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:159)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1334)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1292)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1265)
at ptolemy.actor.gui.PtolemyEffigy$Factory.createEffigy(PtolemyEffigy.java:412)
at ptolemy.actor.gui.EffigyFactory.createEffigy(EffigyFactory.java:209)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:595)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:555)
at ptolemy.actor.gui.HTMLViewer.hyperlinkUpdate(HTMLViewer.java:264)
at javax.swing.JEditorPane.fireHyperlinkUpdate(JEditorPane.java:320)
at javax.swing.text.html.HTMLEditorKit$LinkController.activateLink(HTMLEditorKit.java:827)
at javax.swing.text.html.HTMLEditorKit$LinkController.mouseClicked(HTMLEditorKit.java:637)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:212)
at java.awt.Component.processMouseEvent(Component.java:5504)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5266)
at java.awt.Container.processEvent(Container.java:1966)
at java.awt.Component.dispatchEventImpl(Component.java:3968)
at java.awt.Container.dispatchEventImpl(Container.java:2024)
at java.awt.Component.dispatchEvent(Component.java:3803)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4212)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3901)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3822)
at java.awt.Container.dispatchEventImpl(Container.java:2010)
at java.awt.Window.dispatchEventImpl(Window.java:1778)
at java.awt.Component.dispatchEvent(Component.java:3803)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:163)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:157)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:149)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

History

#1 Updated by Christopher Brooks over 11 years ago

Sorry, I hit return too quickly.

Kepler cannot access MoML actors defined remotely.
The same model works fine in Ptolemy.

To replicate:

1. ant run-dev
2. Getting Started -> Ptolemy introduction -> Documentation
-> Complete List of Demos
3. In the SDF section, click on Network Integration

For me, this model is at c:/cxh/ptII/build/classes/ptolemy/moml/demo/Networked/Networked.xml

4. As the model is opened, a dialog is brought up that asks if it
is ok to access the http://ptolemy.eecs.berkeley.edu.

5. Click "Yes" or "OK" and get the stack trace above.

This is a low priority problem because the feature of accessing
MoML Actors via the web is not used very much.

#2 Updated by Christopher Brooks over 11 years ago

I can't replicate my own bug (Can't access actors via http),
so I'm closing this.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3110

Also available in: Atom PDF