Project

General

Profile

Bug #3216

Demo workflows do not run

Added by Sean Riddle about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
documentation
Target version:
Start date:
04/09/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3216

Description

I have run into a couple of demo workflows that don't run while checking the replacement of the embedded documentation. I will append this with more if I find them.

demos/ENM/GARP_MultipleSpecies-*
Exception - "Actor is not ready to fire. in [workflowname].SDF Director and [workflowname].Get Species/Location information.Line Reader"


Related issues

Blocked by Kepler - Bug #3026: Actor documentation does not appear in older workflowsResolved12/12/2007

History

#1 Updated by Sean Riddle about 11 years ago

ENM/GARP_SingleSpecies_BestRuleSet-IV.xml - After completing its ten iterations, actually crashes the Kepler environment on my system, complaining about JNI.

IPCC_Base_Layers.xml - not a bug necessarily, but it sits in the initializing stage for something like 15 minutes, presumably downloading data, but there's no way to be sure. This would confuse the heck out of me as a new user.

IPCC_Change_MinTemp.xml, IPCC_Change_Precip.xml, IPCC_Change_Rad, IPCC_Change_Wind.xml, - Errors upon opening. Path hardcoded into IJMacro is invalid.

IPCC_Change_NightlyBuildTest.xml - Fails. (And should it be in demos?)

#2 Updated by Dan Higgins about 11 years ago

IPCC_Change_MinTemp.xml, IPCC_Change_Precip.xml, IPCC_Change_Rad,
IPCC_Change_Wind.xml, - Errors upon opening. ---- This is apparently due to the workflow having been saved AFTER being executed on a Windows machine - the file path passed on to the IJMacro get saved. It should not be saved, since it is generated by the previous actor. This is a bug in IJMacro.

IPCC_Base_Layers.xml - Long startup is probably due to large amount of data being transferred, but I don't remember it being 15 minutes! May vary with state of Ecogrid server.

With regard to ENM/GARP_SingleSpecies_BestRuleSet-IV.xml - This used to work OK; what OS, Java version, machine RAM, etc where the problem occurs?

#3 Updated by Sean Riddle about 11 years ago

I'm using MacOS 10.5.2, Java 1.5.0_13, with a 2.4 GHz processor and 2 gigs of RAM.

#4 Updated by Dan Higgins about 11 years ago

It looks like most, if not all, of the problems reported here are Macintosh (and maybe Linux) specific!

I.e. workflows seem to run OK under Windows

#5 Updated by Dan Higgins about 11 years ago

IPCC_Change_MinTemp.xml, IPCC_Change_Precip.xml, IPCC_Change_Rad,
IPCC_Change_Wind.xml, - Errors upon opening. Path hardcoded into IJMacro is
invalid. --- New versions of IJMacro and ImageJ actors have been checked in which avoid this problem (by use of better error trappingl problem occurred only on the Mac. With new code even old workflows with incorrect saved file names will run.)

Dan Higgins

#6 Updated by Ilkay Altintas about 11 years ago

I've sent the list of non-working demos to everyone. It's best to discard them as they are not critical except for a few I mentioned in the email.

#7 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3216

Also available in: Atom PDF