Project

General

Profile

Actions

Bug #3636

closed

Support multiple Report formats

Added by debi staggs about 14 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Category:
reporting
Target version:
Start date:
11/12/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3636

Description

Create support for multiple report formats including specifically the ability to display reports for print purposes and for viewing on the web.


Related issues

Is duplicate of Kepler - Bug #3648: Create Report format converterResolvedben leinfelder11/12/2008

Actions
Blocks Kepler - Bug #3647: Create Report AssemblerResolvedben leinfelder11/12/2008

Actions
Actions #1

Updated by ben leinfelder about 14 years ago

Targeting support for three "formats":
1.) PDF (assembled with XSLT/Apache FOP)
2.) HTML (assembled from Java/XML+XSLT)
3.) AWT (shown in an embedded viewer (uses FOP for rendering)

all three formats are functional currently, albeit barebones

Actions #2

Updated by ben leinfelder about 14 years ago

  • Bug 3648 has been marked as a duplicate of this bug. ***
Actions #3

Updated by debi staggs over 13 years ago

We support the report formats as follows: .pdf and .html

Actions #4

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 3636

Actions

Also available in: Atom PDF